English

Touchscreen doesn't work

Yesterday the touchscreen of my Fairphone 2 suddenly stopped working. It is not that the screen froze, because I can still use the volume button and see on the screen what is changing. If I press the the switch off button, I see the message to switch off your phone, but cannot press it. I therefore restarted the phone by taking out and putting it back in the battery. When I do this or when I press the off button for 15 seconds (to reboot is) I can use the phone as long as the screen does not go into sleep mode. As soon as this happens, I can press the off button to see the start screen, but the screen does not register any touches anymore. Once I restart it again, I can use it again (if I am fast enough before it turns into sleep modus, which happens if I am not paying close attention) until the screen go black… I took the screen off and I’ve put it on again, but this didn’t work. Afterwards, I did a complete reboot (back to the factory settings), but this did not work either.

Nothing peculiar happened to the phone, the problem just seem to appear from nowhere…

Did someone experience the same thing and now how to solve this issue?

Cheers,

Sarah

Ok, that’s odd, so we go for software faults …

If you happen to have a USB OTG adapter, you could connect a USB mouse (and a keyboard, but that’s not so important) with the phone and navigate it this way.

What exactly does it say in Settings - About phone - Build number?

And as crazy as it sounds … Please have a look whether your WiFi is set to stay active in sleep mode. If not, enable this and see if that somehow solves this.

2 Likes

Thanks for the fast answer! :slight_smile:
The build number is :FP2-gms-18.03.1 release keys (I have it about 1,5 years I guess).
I checked the WIFI. It was already set to stay active in sleep mode. I changed it so that it is not active in sleep mode, but this didn’t solve the issue.

1 Like

Ok, the current Fairphone OS with Google Mobile Services then … no update to perhaps help with the situation until the next update is released.

Next try, even if it normally comes with an easily recognizable error message, but who knows … Please check which Apps have permission for screen overlay, here are some examples of problematic Apps in this regard.

1 Like

Thank you. I restarted my phone in safe mode. This didn’t help (while it deactivates the apps I think?). I did a complete reboot to the factory setting, but it also didn’t work… I discovered btw that it is really the black screen that does the trick. For example, if I am calling and do not hold the phone next to my ear, everything keeps working fine. But as soon as I hold the phone next to my ear (and the screen consequently turns black), it does not react to touch anymore…

1 Like

Did you try recalibrating the proximity sensor?

Settings > Maintenance > Proximity Sensor.

That’s usually the cause for a blackscreen when calling. Although it does not really explain the lack of response later.

I did this (as I had problems with this too). Now the black screen only appears when I’m holding the phone next to my ear, as it should be (however causing the touchscreen to stop reacting :frowning: ).

Hmmm … could this be hardware afterall? Can you disassemble and reassemble the screen (here’s a nice video)?

Else there’s still the OS … the so-called “factory reset” is no real factory reset, as it only removes all user stuff and Apps and leaves the OS as is. If there’s something wrong with the OS, there’s still the option to completely wipe the phone and install the OS from scratch.

But first try disassembling the display, it’s much easier and faster :slight_smile: .

1 Like

Thank you for thinking with me, I tried to disassemble and reassemble the screen, but unfortunately this also didn’t solve the issue. I guess the next option is to completely reset the phone? :-S

1 Like

Since you did the so-called factory reset already, I assume you are prepared to lose all data on the phone. With this try, the OS will be deleted, too …

  1. Boot the alternative TWRP recovery without installing it on the phone, here’s how … (and this is no obscure or suspicious software, e.g. Fairphone Open OS uses TWRP as its recovery, too … I’ll use TWRP here because I never used Fairphone OS and its stock recovery, so I don’t know how to really wipe the phone with the stock recovery) …
  1. Perform the complete wipe …
    In TWRP do Wipe - Advanced Wipe - check “Dalvik / ART Cache”, “System”, “Cache”, “Data” and “Internal Storage”, do not check “Micro SDCard” (if available) - Swipe to Wipe

  2. When the wipe is done, turn off the phone.

  3. Manually install Fairphone OS again, here’s how …

If that doesn’t solve the problem, it should be a hardware problem afterall, and you would be left with #contactsupport .

1 Like

Thank you! I just reinstalled the OS, but this didn’t solve my problem either. The phone is also getting quite warm when I am using it, could this point to a hardware problem? I contacted the support team, but I am waiting for their answer.

Thanks for all the help!

Sarah

1 Like

The telephone getting hot (above the battery compartment) is a common issue, that regularly points to an app “running wild”. Usually this is solved (at least it was for me), by rebooting the phone (up to three times).

Support can take a while if you rely on e-mail contact.
Take a look at the thread #contactsupport linked by @AnotherElk. Calling them, having the relevant numbers (IMEI, order no., ticket no.) at hand, usually speeds things up.
Keeping my fingers crossed for you!

I had exactly the same problems.
I also disassembled the screen, but cleaned all contacts. A hint was, that I had phantom inputs that disappeared when twisting the phone. This led me to dust off the contacts.
Then I also had the screen with no inputs and could not switch off the phone.
So I took off the battery and waited for while.
Now it works . Thanks God. :wink:

1 Like

Hi,

Thanks for the advice! Sorry for the late reply. I was on a holiday in Asia. My phone was still broken, at a certain moment it even became worse: The screen was full of static white noise. Then it turned back to it’s previous state again (for two weeks) and then suddenly it was fixed!! However, after half a day, it returned back to its previous state (so no inputs after a black screen). I tried cleaning the contacts. However, I was not sure which contacts and how I should clean them. I cleaned the contacts between the screen en the back of the screen with toothpaste. However, this was probably not the best idea as the problem is again worse (sometimes the screen suddenly freezes, even without a black screen and I have the impression that the sound also became worse)…
As you can read, I am still quite desperate at this moment ;-).
So thanks for all suggestions!
Cheers,
Sarah

Usually alcohol is recommended for cleaning.

3 Likes

I have the same problem. Is there any known solution for this issue?

So the same hints in this topic apply.
Which of those did you try already?

I tried recalibrating the proximity sensor. I did not try any other options like reinstalling the OS since it did not work for Sarah_Beurms.
Any solution for this problem?

1 Like

Since different causes were already identified for this problem, and the cause that applies to your phone is anyone’s best guess, every hint could be your solution … or not.

If you happen to have #fairphoneangels in your vicinity, perhaps the culprit could be identified by module swapping.
Else try Online Troubleshooting and #contactsupport .

1 Like

In this thread there are no causes discussed, only different attempts are described which did not work. Since my problem is exactly the same - touchscreen is not working after “black screen” - I was hoping for an update how to solve this issue. I already contacted the support but did not get an answer.

1 Like