Touch screen activating by itself

The touch screen is continuously acting on its own, especially the quick menu. At first it was at random, but now it is all the time. I cannot get to any menus. And if I let it go on for about 30 seconds, it starts calling, going online and texting as well. I tried to wipe the screen with antibacterial fluid, but with no result. As I cannot get to the menus, I cannot reset anything. Please help. /Kris

Hi Kris

I have the same problem since this morning. Did you get any answers yet?!

This might be a hardware issue. Please contact support.

Also you can do some research in the forum by yourself, just use the magnifying glass above and search for “touchscreen”.

Hi Sarah

  1. First Support suggested that I went back to the previous OS. They wrote:

Currently you are most likely running Cherry 1.6, but with a downgrade to 1.5 this problem should be gone. You can perform this downgrade from the Fairphone Updater app. Here you see which version you have installed. Below this you can see the OS Library. If you click on Fairphone OS you get the option to install version 1.5.

At first I coulden’t go to the menu (becouse of the problem with the screen). I then I was lucky to downgrade. But I diden’t work.

  1. Then I found this post: Buttons pressed randomly - The user “humorkritik” wrote how to test the screen. And I did. In test mode it still activated the red dots by it self (see the post by humorkritik). From the test mode you can also reset the phone without the screen, as it navigates by volume up/down.

  2. When I reset the phone and downgraded to 1.5 and still had the problem in test mode, Support suggested that it was a hardware problem and told me to send the phone to repair.

I hope some of this will help you, but otherwise it is most likely a hardware problem in your phone as well.


Thanks for the reply! I also did this test mentioned by @humorkritik yesterday. I got the same result as you did, so I contacted support. They asked me to do a Hard reset. Did that. Now it stopped flipping out but I cannot use the A or Q when I’m typing a message. The left part (about 5mm) of the touch screen isn’t reacting. (Same place as where the quick menu showed up without touching it). So now I’ll wait for some more news of the support team. Really hope I don’t need to send it back…

Sounds like the exact same problem. For me it’s just the right side of the screen.

Hi all, any updates on this? I’ve got what sounds like the same problem, but it’s on the left hand side of the screen.

Have you done the touchscreen test?

Please continue the discussion here.

This topic is now closed. New replies are no longer allowed.