Time stands still

Since 3 or 4 days I have a strange issue with the time the FP2 (Open) is showing. In the morning, when I check the time (thus waking up the device) it shows the correct time. Then this time does not change any more. This happens in the Uhr widget and in the top right time indication of the top status bar.
Interestingly, if I pull down the screen from the top, there is a new time indication appearing on the left hand side. And this shows the correct time.
Checking in Settings, time was set to be taken from the network (good signal strength, WLAN working). If I change something, such as show time in 12h mode (or so), it picks the correct time - and keeps it. Changing to manually define time, the same, it takes that time - and keeps it.
So time stands still for me currently.

I am not aware of any new app installed or any important update in these days.
I also do not think this is an issue of the device (hardware), but rather some software.
My provider is O2, in Germany. But I think this is not related as time stood still when I went to manually setting time.

While I have been typing this message I set time again to be picked from the network and now it is advancing. (Time to start working now).

Has anyone made a similar observation?
I have not searched the www yet, no time :wink: (obvious, if it stands still there is no time to be spent)

Have you tried to clear cache and date of the Uhr widget/app?
When you long press the new time indication appearing on the left hand it should show you which app is creating this information. Maybe you can search in this direction…

I cleared the cache of Uhr, let’s see how things are going tomorrow.

When long pressing on the time of the swipe down screen, it does not show me anything.

I have the same phenomenon in Fairphone OS 18.09.2 since the last update.

Could someone please explain the way to clear the cache of the clock app with screenshots as illustrations? My phone is in German language and I am unable to transfer the short description in English to what I see on my screen.

Cache leeren

As side note: I realized the Uhr app had no access right to the location (could have been me to remove that, I am not sure). I gave it access now, let’s see if this changes the behaviour. this way, of course the clock did not know which time zone to use.

Also: I checked the other discussions under clock, many also old mentionings of this behaviour. also many on the www (from 2014 to now, on any kind of device). Some work arounds but no real conclusion.

Let’s see by tomorrow


Well, I thought it’s a feature of Android 7.1 that you get options for every of those notifications this way. Maybe I’m wrong.

Thanks, Dietmar. I was studying the preferences of the clock app instead.

On my FP2 with OS 18.09.2 long pressing has no effect either.

:+1:t6:This morning the clock worked properly. I will keep observing this effect and report if the issues appears again.
What I have done:

  • cleared cache of Clock app
  • gave Clock app access right to my location
1 Like

Same with me: Clearing app cache solves problem! :+1:

1 Like

For information, if any of this is useful to someone:
About 3 or 4 weeks ago one day my alarm failed to wake me in the morning. The clock had stopped but started again a few seconds after I checked it. I had the clock screensaver enabled while charging, this showed the wrong time and I think also the desktop widget, and of course the alarm function must have had the wrong time too.
I don’t know if this is the same problem but that is the one and only time it happened in 3 years of the phone’s life. It has been fine again since then.

My clock app has no permissions granted and I’ve never cleared its cache.
FP open version 18.10 (I always keep up with newest versions). Minimal gApps installed plus a few other fairly common apps, nothing very unusual and nothing installed recently except the usual updates. So I assume it’s most likely a system bug.

Hi @Alan_Bradshaw

please see also here: Alarm clock doesn't work properly after Android 7 Update

I am not sure if these are related. In my opinion they might be connected by the improved deep sleep of Android 7, in which case the effect should be observed on other devices as well.

This morning the issue appeared again. Time stands still since 15 minutes now, at about the time when I got up (so about 50 minutes behind), but did not touch the device (ma negligence, desolé).
I will keep it in this state until this afternoon. Maybe it recovers by itself and I can draw a conclusion out of this.

My conclusion is, one cannot rely on the clock of Android 7 devices (the issue is reported with various hardware) especially in the morning. I will go and by an old fashioned alarm clock for my travels.

Edit: We are catching up, now just 8 minutes behind. Go FP2 go!

Edit: During the day I kept using the device as usually. I observed that from occasionally the clock time was updated but it stood still thereafter. After around lunch time where I used the clock app as timer, clock was synchronized with system time.
Still all very strange.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.