Tethering for network connection through Fairphone: windows xp

there is a thread for Linux and Win 7 upwards but it doesn’t work on Win XP. I cannot installe the right driver in order to install the right network adapter (I miss the RNDIS driver).
Where I can I get it?
The solution proposed on XDA Develpors - USB Tethering - Missing RNDIS Driver and blogspot - How to USB-Tether Android phones with Windows XP, using tetherxp.inf are not working.
I know Win XP is absolutely outdated but I can run it as very smallweight VM for all crappy, add throwing, autostart persistent programs.



So, if you’re running windows as a guest, does that mean that you want the network restricted to just the guest (i.e. you don’t want to have the network connection available to the host)?

seems my email reply hasn’t reached this forum:

Yep just for the VM/guest is enough

Routing it trough to the guest make out properly more complicated
sent from a phone

I would expect it to be easier to set up the connection on the host, and to then share that interface with the guest. The downside is that the host would also have access to the connection.
Continuing on trying to connect the guest to the phone directly: Is your device showing up in the windows device manager at all (even as an unrecognised device)?

I would like to keep the guest isolated from the host.
The phone is recognized by the guest, the phone shows up in the Win XP explorer. All what is remaining is the proper RNDIS Driver.

As far as I can determine, the RNDIS driver did ship as part of WinXP, though some differences exist between the different service packs and 32bit/64Bit editions. As you’ve probably seen in tetherxp.inf file, for that you’ll need usb8023m.sys and rndismpm.sys. If the driver installation dialogue claims they’re not on the system and gives you the option to manually search for them, check if you can find the collection of .cab files (Often under Windows\i386) and point the installer at them. The WinXP install disc also has the files.

Not running 32bit Windows? Not getting the driver install dialogue after switching on tethering on the phone? Try the microsoft Remote NDIS INF template for NDIS 5.1 (the top one) just to be sure. Make sure to add the device data as done for the tetherxp.inf instructions you linked to: The ID should be 0bb4:2008 or 0bb4:0c02 (depending on whether USB debugging is set to off or on in your phone), if it is one of those I suggest duplicating all lines that contain USB\VID_xxxx&PID_yyyy and changing this part in one of the lines to USB\VID_0bb4&PID_2008 and in the other to USB\VID_0bb4&PID_0c02. Save the file as a .inf file, right click the file and choose install, or go via the device manager.

Unfortunately, I don’t have access to a WinXP VM to try, so I can only offer these rather general suggestions.

Remote NDIS INF template for NDIS 5.1 and changing

; Decoration for x86 architecture
%RndisDevice%    = RNDIS.NT.5.1, USB\VID_xxxx&PID_yyyy

to my Hardware ID

; Decoration for x86 architecture
%RndisDevice%    = RNDIS.NT.5.1, USB\VID_0BB4&PID_0004

worked out.

The only problem is, that the network adapter remote NDIS based Device shows up only, when USB Debugging is on.
When I switch debugging off and tethering on, the hardware manager shows a new piece of unknown hardware: Mt65xx Android Phone Driver. So I downloaded the MTK USB driver as linked by google on Android Developers.
Once again I had to edit the .inf, in this case android_winusb.inf. I added the following line (4 of 5)

;MTK device
%CompositeAdbInterface% = USB_Install, USB\VID_0BB4&PID_0003
%CompositeAdbInterface%     = USB_Install, USB\VID_0BB4&PID_0004&MI_02

due to

But no new network adapter at all.

So the final question, what do I miss to get tethering to work (or NDIS to show up) when debugging is off?

Here comes the solution:
I added

%RndisDevice%    = RNDIS.NT.5.1, USB\VID_0BB4&PID_0003

just above (or below, as you like) my initial modification of the Remote NDIS INF template and updated the driver of the android phone by this file and voilà :smile:

1 Like

Glad it worked out for you, thanks for sharing the instructions/solution!

Yep just for the VM/guest is enough
Routing it trough to the guest make out properly more complicated

sent from a phone