Sync outlook calendar with FP2?

After a month of keeping track of two agendas, I’m once more giving it a try: to get my work agenda - which is in Outlook - synced with my FP2 calendar.
Previously, I managed to sync my contacts, but not the calendar. So if I go to Accounts and select this Outlook account, I see that “Contacts” is there for synchronisation. But how do I add the Calendar to be synced as well?

I tried adding a new account, but as soon as I add this Outlook account (with my work’s mail address) - this one seems restricted to Contacts as well.

Removing the outlook account altogether and re-include it, still limits it to only the contacts.

I haven’t got a clue, so help, once more is very much appreciated!

Did you try adding your microsoft account as an “exchange” account on the phone?
This should give you the options to synchronize mail, calender and contacts.

It really depends on what kind of email account you have set up in outlook. If it is an ordinary Mail account via IMAP or POP3, it doesn’t have the capability to sync your calendar. Ergo you Outlook calendar is only available on your PC and you would have to look into a synchronization software that will read your Outlook data and sync it to your phone’s calendar. MyPhoneExplorer should be able to do that I think, but it requires you to have your pc with the sync software running and also to have your phone connected by USB or at least in the same wifi.
If you do have an exchange account however, things should be much simpler and you can indeed just add your mail account as n exchange account and it will sync your calendar with the exchange server and from there with your outlook calendar.


Hi ArjenU

As there is no ‘native’ way to sync your Calendar to your phone, I think you only have three options:

  1. Try using Microsoft Exchange.
  2. Switch to Office 365.
  3. Try some 3rd party software for that. I’m usig AkrutoSync to sync my Notes across devices, I guess it will help you to sync your calendars too.

Thanks for all replies. Using Exchange did the work.

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.