Switching SIM numbering

I’m using a FP4 with two SIMs. The SIM I am using most is the virtual SIM. Unfortunately this is labeled with “2”. How can I switch this numbering, so making the virtual SIM “1” and the physical “2”? Thanks in advance.

As the e-sims can be multiple I image the physical sim will be 1, hence the e-sims can be, 2,3,4 . . . .

It may be that the ccoding just increments 1 to the number of sims.

Have you tried removing the physical sim, maybe the e-sim will be labeled 1 but that may be reserved for the physical sim.

By the way why do you want to change the label?


Thanks for your anwser.
I started with a physical sim, moved that to e-sim and added the second sim as a physical sim. As long as only 1 sim was active, there was no numbering at all.
As I said, in most cases I use the e-sim. And it feels a little bit strange to select no. 2 when I choose my favorite connection. But, in fact, it is increasing convenience a little bit, not solving a real problem.

1 Like

You won’t be able to change the numbering, but you can at least give them a catchy name and different colours under Settings → Network and Internet → Mobile Network → [Name of Provider]:


Thanks for the advice. I already did that, but in some cases only the number is shown, e.g. my dialer only shows the number.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.