English

Switching from microG to OpenGApps

Tags: #<Tag:0x00007f05ec8b0350> #<Tag:0x00007f05ec8b0210> #<Tag:0x00007f05ec8b00d0>

I’m running my FP2 on FP Open for some time now and I spent considerable time trying to properly install microG, but still for some apps don’t work at all and for some push notifications don’t work. So I decided to bite the bullet and install OpenGApps instead.

Since I also have Xposed installed I followed the update guide and installed an FP Open update, OpenGApps and Xposed in one go with TWRP without rebooting in between and wiped the Dalvik & cache. I hoped the FP Open update would revert the system to default state, since the installation instructions for OpenGApps mention that.

So far it mostly works fine, but I have the problem that when I login with my main google account the Play Services seem to be crashing after completion of the login. It’s fine all the way until accepting the terms, but when I press the button the window just closes. I even got an email notification for the login, so password etc. was fine. Login also works with my secondary Google account. Does anyone have an idea what the issue might be?

The OpenGApps FAQ mentions to do the following steps: manually wipe (format) your System partition, flash your ROM, flash Open GApps package. However I don’t know which of the FP Open packages I could use for these steps, since there’s only updating and switching packages.

We are talking about this guide? …

https://forum.fairphone.com/t/pencil2-update-guide-for-a-modified-fp-open-os-with-gapps-xposed-and-more/21117

The guide says …

Currently there’s only one file there that matches this, it’s the OTA file.
Furthermore, the guide suggests installing with TWRP, and TWRP can only install the OTA file.
The other files are named “manual” and need to be installed with #dic:fastboot following the manual installation procedure given here for Fairphone OS … https://support.fairphone.com/hc/en-us/articles/207914363.

The “OTA” and “Manual installation” files, despite being labelled “upgrade”, are working for full installs from scratch, they are not only updates or upgrades. The switcher files don’t work for full installs from scratch.
I agree it could and should be made clearer on the page what each file is intended for.

If you really want to go for default state, I suggest doing more …

1 Like

Yes, that’s the guide I followed. Thanks for the clarifications about the files and the link to the reset guide! Doing a full reset would be the last resort. However, since one of my google accounts works, I’m not sure if it’s an issue with the setup/installation or just something with the specific account.