Sudden serial crashing - wi-fi setting related?

Recently my phone lost connection with the wi-fi, and couldn’t get it back when I was in range of two networks, one of which it should connect to automatically. I tried to turn the wi-fi off and on again, and the little “Wi-Fi networks available” notification popped up… and up… and up. Then the phone crashed.

It’s repeated this behaviour every single time I’ve restarted it. I can’t access the wi-fi settings at all - if I try, settings stops working, and then the phone crashes. (It turns off - either goes straight through the startup process, or has to be restarted by taking the battery out and putting it back in.) Also, I sometimes still see “Wi-Fi networks available” even when the wi-fi is off.

Having read that restarts like that can be a SIM-card issue, I’ve taken mine out - no luck. I’ve tried putting the phone in airplane mode, but of course it still searches for wi-fi, so I see the message pop up anyway. When I turn off wi-fi completely (if I can get that far), the phone goes for a little longer without crashing, but we’re talking a few minutes at the most.

I noticed when I had the SIM card in and got data connection that the system started trying to load a Fairphone update - didn’t seem to get anywhere though. And even though I’ve set it to not sleep for 30 minutes the screen will turn off almost instantaneously if I’m not touching it, and then the phone (not just the screen) is off.

I’ve tried uninstalling any recent/suspicious apps, but that’s done nothing. Am I looking at having to do a factory reset? I’ve got backups of personal data on an SD, but if there’s any way around having to redo all settings to all apps I use daily, that would be fantastic!

You could try installing Xposed with its XPrivacy module and then block all activity trying to check if there is any app which tries to power up your antennas without authorization.
If you can’t manage to find it, I fear your last resource is a factory reset
Bye! :smile:

EDIT: thanks @paulakreuzer for providing links (I wrote the post in a hurry!)


Thanks for the tip, DjDas! Might be good to get it for some housekeeping.

My issue does appear to be sorted for now - I think there was a connectivity conflict, and when I got myself away from one of the two networks before starting up, the phone connected normally to wi-fi and has stayed on since. I guess it was just a (rather terrifying) glitch. Fingers crossed that this issue is fixed for good!


The topic will autoclose in 10 days. If the problem returns you will still have time to post. After the ten days, please click the flag symbol and contact the community moderators, if you need the topic reopened.

1 Like

I would be interested if you can reproduce the error. Sounds awwwwefully annoying.

If it happens again, I would suggest you try to clear the cache in engineering mode.

I think it was a perfect storm of making an attempt to connect to a new network in the same microsecond as the standard network suddenly became available - I’m fairly sure I couldn’t make that happen if I tried! I was just exceptionally (un)lucky in achieving that effect. It’s now been 24 hours, and my phone has been its usual splendidly useful and harmonious self, so I’d rather not tempt fate by trying to double-connect again.

Will have to read up on stuff like clearing the cache in engineering mode, though - might be useful even if the phone is not so confused by wi-fi issues that it crashes in sheer panic…


This topic was automatically closed after 10 days. New replies are no longer allowed.