English

Stuck on start screen and don't have access to the blue screen

Hello

I wanted to update my Fairphone 2 and since then my phone is stuck on “fairphone change is in your hands”. And I can’t access to the blue screen for making a restore…

Have anyone any ideas how I can restore my phone?

Thank you!

Hi and welcome to the forum,
I assume you use the standard Fairphone system?/ if so I would advise to manually install the update again

2 Likes

Hello yvmuell!

Thank you for your quick reply :slightly_smiling_face:

I tried so but as I cannot access the bootloader (the blue screen), the script cannot find my phone (see attachment)

Do you have any others suggestions?

So when you “start” the FP with Vol-down plus Power it won’t boot into fastboot mode? So no Blue LED no vibrating and then stuck in Fairphone Logo?

Normally when you see this you can try to update the driver.

On windows 10 go to windows updater, search for updates, click on additional updates and driver. Select everything with Google…

Else can you boot into recovery, Vol-up plus Power?

1 Like

When I start with Vol-down + power, I have the vibrating and the blue LED but the screen is still stuck on the Fairphone Logo…

And when I tried to boot into recovery (Vol-up + Power), the attached message appears…
14928760754449

I will try as you said to update the driver!

This is what you need to manually install, so you need to update the driver

1 Like

Here is what appears now…

And I tried few times to restart it, but always the same message… I’m starting to get desperate :frowning:

There are reports that confirm that patience will help, along to try over and ove r again to run the script…after many attempts it finally worked…

Edit:it might be worth to try another cable

2 Likes

I hope the flash memory is not dying…

You mean by trying to many times? Or it could be the source of my problem?

Maybe it is the source, but I would follow the advice of @yvmuell first and try again with another cable, if possible. The microUSB socket of the phone could also have an issue…

3 Likes

I changed the cable but still not working… I’ll try with another computer tomorrow morning

Here is the further I could go:

Hi guys!

I succeed to reboot the device with the oldest version of Android (Android 5.1) :partying_face:
But now I have a black screen… When I’m pressing the power button, the phone vibrates but nothing appears on the screen…

Any suggestions?

Your FP2 most likely has a newer display module for which the Android 5.1 ROM is not prepared:

Unfortunately the article mentioned is no longer online…

2 Likes

I think this is somehow covered in the instructions for manual installation and you should still be able to use fastboot to manually install. However I would not go from 5 to 9, but step by step from 5 to 6 and so on…

  1. Your new display stays black

The procedure is the same in both situations. However, if your new display stays black you will not have visual feedback of what is happening in your Fairphone 2 during the process

For official FP help you could open a ticket in the bug tracker, the developer would know better if you can skip Versions or not.

2 Likes

Thanks everyone!! After rebooting in Android 5.1, I’ve done what @DeepSea suggested: I rebooted in Android 6.0. There, the screen was functional but the phone would restart every 3 secondes without any chance to do anything… So I rebooted it in Android 7.1 and now it seems to be fine except the pull down menu and the “open Apps” button that are not working anymore… I will check on the forum if I find the solution to this problem.

Anyway, thank you again for your time and your help!!! :smiley: :smiley: :smiley:

2 Likes