Stuck on fastboot during /e/ installation after rooting the phone and locking the bootloader

I’m stuck on the fastboot mode, here is what I did :
I unlocked the bootloader following the official instructions
Then I followed the instructions on /e/ website except the final step

fastboot -w
 fastboot flash system system.img
 fastboot flash boot boot.img
 fastboot flash vendor vendor.img
 fastboot flash dtbo dtbo.img
 fastboot flash product product.img
 fastboot flash vbmeta vbmeta.img

 fastboot flashing lock

I booted on the freshly installed OS, everything was fine, but I wanted to be root.
I followed these steps How to root the Fairphone 3?
I then rebooted on the OS, I checked I was root, everything was working as expected
I decided to run the last install step ( fastboot flashing lock) now, thinking it was more secure to do so
But at reboot it did not boot correctly, I had to choose between retry and reset to manufacturer’s. I retried twice without success, so I reboot to fastboot mode and took the installation’s step for /e/ again

   fastboot -w
    No error
   fastboot flash system system.img
        Sending sparse 'system' 1/4 (522236 KB)            OKAY [ 15.794s]
        Writing 'system'                                   FAILED (remote: 'partition table doesn't exist')
        fastboot: error: Command failed

Since then I’m stuck in fastboot mode, I rebooted manually, got the battery off, launched fastboot reboot, nothing is working
I tried to boot twrp with fastboot boot twrp.img but I got FAILED (remote: unknown reason)

Couldn’t find similar problems

Thanks in advance for your time

Welcome to the community forum.
I edited the topic title to better reflect the actual situation.

A bit further in this topic …

And you unlocked the bootloader again for this?

Thanks for your time
Gosh, I did not see you could not relock the bootloader…
I did not unlocked again, as its wirtten on the phone “DEVICE STATE - unlocked”
But I tried again and the command returns Device already : unlocked !

found someone with the same problem, but his solution does not work for me Device stuck in fastboot mode after oem re-locking

1 Like

./fastboot getvar all
showed (bootloader) current-slot:INVALID
So I did ./fastboot --set-active=a
From there I could do a factory reset


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.