English

Stuck in TWRP after trying up update Android. Can I back up from here?

I have a Fairphone 2 that has been running fine for a year or more with Android, not sure what version. I got a notification that I should update to a newer Android (again, can’t remember the number) and said ok. I didn’t think to create a backup beforehand.

The update started ok but then it crashed and the phone went to the ‘Team Win Recovery Project’ thing (I didn’t know this was a thing before last week so please explain everything very slowly in your answers, I’m a total Fairphone novice). I tried rebooting (using the ‘reboot’ button in TWRP, the power button for 15 seconds, and taking the battery out) but it restarted into TWRP again. I think I tried a couple of the other things in TWRP but didn’t know what they really do (I can’t remember what I tried now because this was a few days ago).

I think I need to wipe the phone and reinstall the OS but I don’t know how to do that and I don’t want to lose everything on my phone. I’m not really worried about photos (they should all be backed up on Google) or music/videos (I didn’t have any), but I would be really sad to lose my WhatsApp chat history as it has some personally important stuff in there. I had turned of the Whatsapp automatic backup (yes, stupid of me, I know) so now I don’t know if I can recover it through the TWRP thing. My battery drained super quick in TWRP - even plugged into my computer it went flat in a couple of hours!

So my questions are:

  1. Why did my battery drain so fast and is there a way to get it to charge up long enough to fix anything?
  2. Can I get at my Whatsapp chat logs through TWRP to back them up somewhere? (FYI I use Linux on my laptop if that matters)
  3. Once I’ve done those (if I can) how do I reinstall the OS?

As I said I’m a total beginner at this so please explain everything very clearly without jargon. Thanks!

A post was merged into an existing topic: Stuck in Team Win Recovery Project after Android update