Stuck in load screen after updating to FP Open OS 16.11

After updating to FP Open OS 16.11 I am stuck in the load screen.

The update seemed successful & after the usual reboot I entered TWRP again to install openGAPPS and XPOSED Framework from my sdcard. When I rebooted to start the phone, entered my code - phone is encrypted - but after that it displays a flashing “Loading”-screen and nothing happens.

I think it might be because the version of openGAPPS I installed from my sdcard was from August 2016, so probably not the latest version. However, I’m at work now and don’t have any microsd adapter etc on me to copy the newest openGAPPS to my microsd. Is there any possibility to copy something from my computer to the phone’s microsd while in twrp or using adb or fastboot (and if so, could you give me a hint how to do this, please?)?

I have a Titanium Backup, so wiping and restoring would also be a possibility, but I’d first like to try with installing the most recent openGAPPS version - or any other simple fix, if someone here happens to have an idea?

Thanks a lot for you help!

JohannesCommunity Moderator

First I flashed the XPosed framework version 87-sdk22-arm, than I updated to 16.11.0.

This is a good point (so it’s worth repeating). For Xposed users: you will need to update to framework version 87 (either before the 16.11.0 update, or immediately afterwards). Versions 86 and lower are NOT compatible with the Android November security patches included in this update and will cause a boot loop.

1 Like

It is possible to copy files via ADB in TWRP. However, you may need to first flash the latest community port of TWRP (i.e. replace the recovery), which allows you to use ADB in TWRP. Mind though that you will need to have USB debugging activated in your OS. If you didn’t do that earlier, it may not work.

If you just want to copy a file to your SD card, you can also connect your phone via MTP to your computer. This works in TWRP as well, independent of having USB debugging enabled :slight_smile:

Ah, so it’s Xposed not openGAPPS? Ok, I’ll get the most current versions of Xposed and openGAPPS then & try it. Thanks!

Could be both.
As @Heiner said, xposed v86 or older is incompatible with the November patch level. See here for details.

However, I also ran into problems earlier with installing old opengapps versions. And there was a GMS update recently, so this may cause troubles as well.

For this purpose I always download the latest opengapps and xposed versions before updating Open OS.

Hm, MTP means using Android File Transfer (or similar software), doesn’t it?
I tried that, but the phone is not recognized, when in recovery…

Re flashing TWRP - I couldn’t manage to connect with my device in fastboot before (no devices found), so I’m considering to wipe via TWRP and restore with Titanium, before things get too complicated. Does a factory reset with TWRP restore to FP Open OS or to regular FP OS?

…and of course you are right and it was pure negligence on my side that I didn’t download the most current version before :expressionless: Lesson learned!

I don’t think you need any extra software for MTP. Just tried on my work computer (Win7) and it was as simple as pluging in the phone (in TWRP) and having access to the SDcard.

Too bad if fastboot won’t work. With fastboot you could have also flashed the /system.img from 16.10 again and then download the files on your phone.
What you still could try, if you have the file available, is to use the and “update” from TWRP the old OS version. I am not sure if that works, but may be easier than having to restore the device.

Open OS.

Afaik, the factory reset just wipes the /data partition.
Which makes me wonder: I am not even sure if it will help you if you have already installed an incompatible xposed framework. You could uninstall the xposed framework, but then again, you have the same problem as before: You’ll need to copy the uninstaller first to your device.

If you want to repair it asap, I would try to get fastboot working.
What could be more convenient: Ask someone around you with a working phone or any other device that can hold a microSD to quickly put your SD inside, copy the files onto the other device, and get the SD back to your phone.
If you have the right xposed (and maybe opengapps version), it should work fine again after the installation.


Yeah, strange fastboot doesn’t work. I’ll definitely try to figure that one out once the phone is back up and running.

I think your last suggestion about using someone elses phone with my sdcard is a very feasible option for now - thanks a lot for the pragmatic solution! I’ll try it asap and report how it went :slight_smile:

You don’t need to have USB debugging enabled in the OS as I have turned off “adb verification” (or whatever it is actually called) off for TWRP as I needed it like that. And when somebody has access to your phone, he can do whatever he wants anyways… (or flash a new recovery via fastboot)

Thanks for clarification and good to know! :slight_smile:

So I guess this is also the reason why ADB works with your TWRP version also on encrypted devices (since I thought that the key is stored somewhere on /data)?

1 Like

All was well: Installed newest OpenGAPPS and Xposed-Framework, phone booted, optimized apps and now works perfectly. Thanks a lot for your help (again)!!