Stuck in FastBoot Mode on stock Fairphone OS

After power-off unable to boot. The phone shows the Fairphone logo on a black background and vibrates, but then instead of a blue screen with moving dots it turns black and the cycle repeats.

I managed to enter the menu by holding Power and VolumeDown. It allows to choose between START, Restart bootloader, Recovery mode, and Power Off. All of them do nothing, except Power Off indeed cuts the power.

Although, I tried to select each option while charging or with connection to PC or while charging without a battery. Nothing helps, but the last option just shows an image of a red battery.

On the Screen, I see:
FastBoot Mode
Prodname - FP4
Variant - SM_ UFS
Bootloader version - [empty]
Basebend version - [empty]
Serial Number - [my number]
Secure boot - yes
Storage size - 240
Main Memory size And Vendor - 8GB Uknown
Display panel name - [my name]
Device State - locked

Also tried to connect via adb, but the phone just isn’t on the list of available devices.

Are there any other options except writing to support?