Stuck in bootloop, cant get into fastboot mode :: eOS

Hey,
I have just updated my E os and wanted to reapply root. So I did the usual of downloading the boot.img, patching it with magisk, then booting it with fastboot and then rebooting.

Everything went as planned, but the last step. Here in a bootloop, that I am unable to recover from with my knowledge.

My current situation: I try to start the phone, usual bootloader is unlocked message appears, then it goes into booting e os.

I tried to get into the fastboot mode by pressing volume up and power button. With this I sometimes got into a mode where only some charing symbol appeared and my pc said that some device appeared, buut neither adb nor fastboot are able to recognize the device.

Then I read I am supposed to get into fastboot mode using volume down + power button but with this I got nowhere.

Any pointers how I can recover from here?

Cheers!

The fastboot mode on the FP4 is reached as described here the button combination you mentioned would not work as far as I know

Alternatively, you can disconnect the USB cable, turn off your Fairphone, then connect the cable and hold the volume down button. After a few seconds, you’ll see the fastboot mode.

4 Likes

You are a legend. Indeed. I completely misremembered :slight_smile:
I manged to get it back.

2 Likes

For your next update, there is a safer/better/easier way to update a Magisk installation.

Follow the part for “Devices with A/B Partitions”.
I successfully used this way on pure LOS and iodéOS, it should work the same on /e/OS. Maybe I used it even on /e/OS, but I’m not quite sure about that, it’s too long ago.

1 Like

Thank you for pointing this out. Definitely going to look into this. Got a little spooked.
I learned a lesson and started with making a backup though :smiley:

I also think I know what happened. I think I flashed the wrong boot.img which was incompatible. I had the e/os version 1.5 on the phone but used the boot.img 1.5.1 by accident.