Strange screen issue

Thanks for the reply! That’s really useful information. I’m glad you managed to solve it :slight_smile:.

Sounds very much like a core module problem then. I think repairing that might be a bit out of my comfort zone, but I’ll have a look into it (or getting a second hand module on the forum’s marketplace). I’ve had it for 3 1/2 years so it’s not in warranty any more.

In it’s current state it is becoming unusable, but I feel optimistic that I can keep my FP2 going a bit longer :blush:.


1 Like

Hello again.

I’m just trying to troubleshoot a bit deeper and see whether it is a hardware or software issue :face_with_monocle:.

I’ve managed to get a logcat of the “incoming call crash” I mentioned above.

I’ve tried finding a guide, but haven’t managed to find anything illuminating. Can anyone point me in the right direction? There appear to be a lot of graphics related errors that I don’t understand. I have LineageOS 17.1 (latest build) with pico opengapps.

Many thanks.

PS: If it’s of interest, what’s the best way to share the logcat file here? The forum won’t let me add a text file.

You may zip the logcat and add e.g. “.ttf” at the end of the filename. Then you can upload it to the forum. You should mentioned that anyone downloading it should remove that extension…

Or you can surround it by the tags
[details=“Click here to see logcat output”]
your logcat output as text

It would look like that then:

Click here to see logcat output

your logcat output as text


Thanks Volker :slight_smile:! Smart workaround.

So for anyone who would like to take a look. I’ve attached “”. Please remove “.ttf” from the filename and unzip to reveal the logcat.

I’ve started the logcat just as the call comes in, but I get a similar behaviour when an app crashes. This is now happening more often (5-6 times a day), but it always appears to recover after about a minute or so with a “Close App” message.

I’ve tried looking up the different entries, but I haven’t manged to find anything relevant online. To me it looks like the error occurs at 15:02:38 with a whole series of GPU related entries. This roughly fits with me observing the screen stuttering for a second or two before the screen freezes completely. The ring tone continues to play and stops as it should when the other person hangs up.

Any help is appreciated. I guess my initial question is, does it look like a hardware or a software issue? My instinct is a hardware issue, as it appears to be getting worse.

Thanks for looking. (29.6 KB) [running LineageOS 17.1 (latest build)]


I have the same issues (strange screen issue + incoming call screen issue). The “App isn’t responding” issue described by @gapintheclouds also happens with other apps. The worse is when it happens with the clock app and I can’t turn off the alarm in the morning…

I will try to make some tests during the holidays as I have a second FP2 I can use in the meantime. Until then, I tried the advice found in another thread: I turned off the transition animation scale, the window animation scale and the animator duration scale. I have had just a few app crashes in the last 5 days and never with the phone app. So I’m pretty happy that my elderly FP2 isn’t dying after all. Not yet!


The behavior has nothing to do with the OS. I’ve test LOS, Fairphone Open as well as /e/: The artefacts and the freeze occurs in all 3 OS. It seems to be a GPU-issue - a manufactured or damaged chip.

See also Fairphone B.V. won't repair FP2 which is within warranty? (with screenshots).

1 Like

Thanks @chrisse. I tried the advice in the thread you found, but it didn’t make a difference. It took a while as it kept crashing while scrolling in the Settings app.

But since then a generous person sent me a spare core module they had and it’s all working again. I’m now thinking about how I can prevent this from happening again. If it’s because the GPU is overheating, does anyone know if it is possible to minimise GPU usage? I can disable the animation settings mentioned in the link in the post. But are there any other methods in Android to do this? I’ve had a look and I can’t find anything useful.

For reference, I managed to take a picture of the split screen issue I was having (below).

1 Like

Hi, I’m wondering whether to use this method to fix. Could I ask how much it cost to fix by Fairphone please?

@LL435 I already answered you in the PM you sent me, but here’s the same info in case anyone else is wondering:

My device was still under warranty when i sent it in to be repaired, so I actually didn’t end up paying anything. Fortunately, though, there was a mix-up at the repair center and I got a quotation document / bill after they diagnosed my phone. So I still have the information you’re after :slight_smile:

The shipping was free (not sure if this was because of warranty or do they do this with all cases). The price of fixing the phone was 165,83€, VAT included. I was also given the choice of not getting the phone repaired after all, either getting it shipped back to me in the condition it was in (this option was 15,30€) or having the repair center destroy it (free of charge).

1 Like

Hi, thank you very much for the reply and the information. Our problem is exactly the same as you had. I think because our phone is 6 years old then, if it’s likely to cost that much, we may put that money towards a new FP3 instead as there’s no guarantee something else might go wrong. Thanks :slight_smile:

1 Like

Hi @gapintheclouds,
After re-reading this thread, I am wondering if you already had these problems before Lineage 17.
I have experienced the same issues as you on Lineage 17 (I think it started on 16 already). Then I did a complete reinstallation from scratch and installed /e/ pie. I haven’t had any troubles for 15 days (some mild dots like @morgenstern’s pictures in the first post, but not as bad). Then I have upgraded to /e/ Q and some of the problems are back. Mainly: the dots appear more often and are often followed by an app freezing. It happens a lot with my news app, so I thought it might be related, but it also happens with Signal.
I upgraded yesterday and I already have had 3 freezes today.

Could it be Android 10 -related? I would guess not, because I think that I experienced issues on Lineage 16, but the problems appearing with my upgrade are quite obvious. Could it be something else related to my upgrade, but not Android-10 related?


Hi @chrisse.

Thanks for the interesting information. I still have my old core module, so I’ll try downgrading to Android 9 Pie (LineageOS 16.0) and see whether I can get it working. I bought it factory-refurbished about 3.5 years ago and I always had some very mild dots on that core module but then the “screen splitting” started and after a few months it became unusable.

I have Android 10 (LineageOS 17.1 variety) installed on my “new” (second-hand) core module and it works without any issues, so that would mean there is a fault with the old core module that I haven’t got with the new core module.

I don’t know much about Android, but I’m wondering whether Android 10 uses parts of the hardware that Android 9 does not. There error message in the logcats I got would indicate that it might be graphics related. Would there then be a way to turn off whatever is different in Android 10 to get a working phone again?

Anyway, I’ll try Android 9 on the old module this week and report back.

1 Like

I have similar graphical problems and turned off the overall animations a few days ago. This makes Android (LOS 17.1) run smoother and I haven’t had any graphical problems since then (but as I said - only a few days ago).

My wild guess is that the overall animations in Android 10 quickly pushed the FP 2’s graphical performance to the limit, resulting in freezes and these graphical errors.

… I could be wrong, but feels promising :slight_smile:


That’s what I had done on LOS and it helped. Not perfect in the end, but less problems and only with some apps (as where before I had problems with the clock app and the phone app…).
But in my case, I am really interested in the fact that just upgrading to Android 10 has such effects. What you say could be related to what @gapintheclouds thinks.
Thanks to both of you!

I will try to see this week how it goes. Right now, I have uninstalled my news app and I use their website instead. Much smoother and no problems so far.


I installed a number of distributions on my “old” core module and tried a number of things.

  • LineageOS 17.1: Just scrolling through the settings menu was enough to cause a crash.
  • LineageOS 16.0: Better, but it crashed after a minute or so watching a youtube video in the stock browser.
  • Fairphone OS 21.01.0-rel.0 (Android 9 release candidate) [with Google services]: This seemed more successful. Managed to play a whole 10 minute youtube video in Firefox. Streaming video in the BR Mediathek and BBC iPlayer apps stopped after about 30 seconds. Other than that, the phone seems stable for browsing. When I enabled ‘Hardware Acceleration’ in Settings > System > Maintenance, that then caused the youtube video to crash after a few seconds (but the sound continues).

Haven’t tried regular Faiphone OS (Android 7.1).

It’s pretty basic testing, but might be useful :slight_smile:.

1 Like

So, I am back on Fairphone Open OS (the new Android 9 release) and I think that it’s the best so far regarding the screen issue.
After a long time on Lineage 16 and 17, I had tried /e/, but after a promising start, the problems got back quickly. Signal froze often and so with the browser when I was reading the news. Nice split screens as in post #16.
On FPOOS, I notice some lag sometimes exactly when the apps would froze on /e/, but they don’t freeze, I can go on. Rarely, I have had an app restart, but much faster than the freezing process I had on Lineage and /e/.
The only problem I have encountered so far is with the clock app and the phone app when the screen is off. I had the same issue on Lineage, but not on /e/. I can see the alarm ringing (or the phone ringing), but the screen seems unresponsive. Sometimes, when trying to take the call or to stop the alarm, the lock screen pattern would appear at the same time than the phone app or clock app screen. I guessed that the problem could be related to the lock screen so I deactivated the pattern and only uses the swipe for now (to test). No problem so far.

It’s been only one week since I installed FPOOS, so problems could come back, but maybe others with the strange screen issue would like to give it a try.


I’m also seeing the same type of artifacts on my FP2. For me, they started shortly after my screen was replaced by FP support under warranty in March 2018. Since it didnt affect usability really, I just ignored the issues then. I suspect a software issue, since I could make screenshots of the artifacts.

Recently, I’m starting to see other issues. In particular occasional apps crashing and phone resets. I’m not sure if these are really related, but one issue does seem related: The clock app freezes up often when an alarm goes off. Until now, I hadn’t really investigated (it happened when I woke up, so I just force reset my phone to get it to shut up ASAP), but now I tried to reproduce it and noticed that the alarm UI starts up normally, then these artifacts appear and then the UI freezes (though the phone itself still responds very slowly, if I tap the screen, wait 10-20s it shows the “Clock is not responding” popup, if I click “close app” or so, wait another 10-20, the clock is killed and the phone becomes responsive again). I’m not entirely sure the artifacts happen every time it crashes, but 3 out of 3 times today. I think there are also other threads about the alarm clock issue, but for me it seems to be connected to the artifacts.

Given the artifacts started for me and the original poster after the screen was replaced, that would suggest a problem in the screen module, though some comments above (i.e. Strange screen issue - #11 by helmituuli) suggest that replacing the core module helps. Maybe there is a compatibility issue between old core and new screen module somehow?

I had also hoped that his would be some software/configuration issue, but today I switched from FP open OS 19 (Android 7) to Lineage 17.1 (Android 10) and the issue still occured on a clean install (no additional apps installed, only enabled adb and changed a handful of vibration settings). I’ve also done a thorough cleaning of all modules and their contacts, which didn’t help. I’ve seen the issue with and without a SD-card installed, with and without a charger attached, so none of those seem related.

Above suggests that GPU overheating might be involved, so I guess I’ll try stress-testing the phone and checking the temperatures and maybe disabling animations, though I’d be surprised if the alarm app would load the GPU so much (though it does display a fancy animation, and it does take a few seconds for the problems to start, so maybe…).

About the clock app: do you have a screen lock pattern/nip? If so, can you try with only a swipe instead (you can put back the pattern/nip in the morning after the alarm), just to diagnose if the issue is related to the lock screen like on my phone.
I also have encountered issues with the clock app when using the stopwatch: when I use the “interval” function, the app seems to freeze (the count stops), but still works in the background, so that I can close the app and open it again and I notice that the counting had continued; then it seems to stop again, but works in the background; not super easy… BUT when I use the stopwatch without the interval, everything works fine.
The theory about the screen seems interesting, and it might work for me (I replaced mine before issues started, I think), but I wonder how the stopwatch issue could be related. I will try to put back my old screen to make some tests. I still works, but the right part is unresponsive.

Nope, just swipe lock now and also before.

I’ve seen issues with the stopwatch and/or timer before as well, which originally lead me to believe that timers or timer interrupts were somehow involved. However, my meditation app has not once failed to time its ring properly, so maybe it’s not that and it’s the fact that the alarm, stopwatch and timer use animations and/or fast screen updates maybe… Might also be that there’s multiple unrelated issues, of course.

What do you mean by “Interval” function of the stopwatch? The lap function?

Furthermore, to explore the overheating theoary, I tried running the “CPU throttling test” app, which ran without problems (core temps around 70-80° and 60% throttling, but no display artifacts or crashes). Might be that this just loads the CPU, not GPU, of course.

Next, I tried disabling animations, which allowed the alarm to work ok 3 out of 3 attempts, but then I re-enabled animations, and the alarm also worked ok 4 out of 4. I wonder if the charge level is relevant here, since the CPU test drained my battery from full to 79% (and the alarm problem usually occurs when my phone has been charging all night). I’ll fully charge my battery and see if that helps to reproduce the problem (though I’m pretty sure I’ve seen the screen artifacts also when the battery was not fully charged during normal operation during the day).

Update: Charged up to 90% (green charging light) and tried again, clock crashed again immediately two times (though without display artifacts this time). Then once (down to 89% now) artifacts where visible, but the clock didn’t crash. Then once more crash without artifacts…

Then disabled animations, and alarm worked without problems 3 times (battery 87%). Re-enabled animations, crash without artifacts once, no crash once, another crash without artifacts (battery 86%). One more crash without artifacts at 83%.

Yes, I wasn’t sure about the English translation, so I guessed they would call this function “interval”, as I have an app called “interval training”.
This app was also problematic in fact, it always stopped, either restarting the app or the phone.

On my side, I did some tests with my old screens and it seems to work better. I will have to keep it a few days to be sure it’s related before I can draw any conclusion. Most of my tests with the stopwatch were positive. Once or twice the app restarted, but quite fast and without the frozen effect.