Stock firmware needed - partition table deleted

I wanted to install lineageOS on my FP3 via TWRP (for convenience, as I’m used to it and thought it would make installing my old FP2’s backup on it easier).

In TWRP, in “ADB sideload”, before actually starting the sideload, there were 2 optional boxes to check and wipe. Accidentally (or cause of stubborness), I did so. I guess that’s the moment of failure, aka deleting the “partition table”, but I’m very happy to be corrected here!

I wasn’t yet aware of something being wrong, and I could still install lineage to the inactive partition (B). I got confused by TWRP’s message “No OS installed!” when I wanted to reboot, but figured out this message is caused by the fact that the OS is on the inactive partition. Right? Anyways, I rebooted, and lineageOS is there, ready to use.

Yet, as mentioned before, I wanted to use TWRP to install my old phone’s backup. I tried to reboot into recovery, but it was stock recovery. I realized that TWRP is installed on the other partition A, or at least that’s what I assume, but again happy to be corrected!

Now, I thought that wasn’t a problem, as I could flash TWRP to the active (B) partition. But turns out, this doesn’t work. If I run
fastboot flash recovery <path/to/twrp.img>
I get the error:
FAILED (remote: partition table doesn't exist)

Asking ChatGPT how to solve this, it recommended to re-install stock firmware, and then re-installing lineage. Sounds reasonable to me, but I’d appreciate your opinions!

And if so, where do I get the stock firmware from? I found this one forum entry
TWRP installable stock firmware packages for Fairphone 3
but I’m a bit scared by all the comments saying it didn’t work or ruined the phone… (Also, I’m confused by the 2 different links in there)

As I don’t want to ruin my phone any further, I’d be very happy to know what’s the right thing to do! Thanks a lot to all of you! :pray:

First of all do not flash TWRP only boot into.

chat GPT?

Actually as long as the bootloader is unlocked there should be not a big chance to completely brick the phone, so I would just manually install stock and Start from scratch

I think there is no need to re-install the stock firmware and then lineage again afterwards as it wouldn’t change anything. No partition got deleted, the FP3 simply has no “recovery” partition, i.e. reverting back to stock ROM wouldn’t restore it.

Using TWRP to create/restore a backup to my knowledge would require to each time boot TWRP via adb (which in turn requires an unlocked bootloader) and you can’t flash TWRP to the FP3.

Edit: wait, you want to restore a backup via TWRP that was created on a different phone which isn’t an FP3?
Does that make sense?

To be absolutely clear when you do something like this:

  1. Creating a full backup in TWRP (including /data partition)
  2. Factory resetting your phone
  3. Restoring your previously taken full backup
  4. Result: all your saved data will be there but your data on the internal storage gets LOST!

And taken from What should I back up in TWRP?

The default backup options in TWRP are system, data, and boot.

If the backup wasn’t created on an FP3 I think restoring system and boot would be a desaster.
I’m not sure what is in the “data” backup when it does not contain the internal storage. Probably your installed apps, but I’m not sure.

Maybe also relevant: What is a data/media device?


Thanks for your answer! Maybe a stupid question, but why shouldn’t I flash TWRP? I might be ignorant, but that’s how I used to do it on my FP2 and I was always quite happy with it…

ChatGPT - I’m not a huge fan, but it proved to be pretty helpful cause you can keep asking until you feel like you understood, and you don’t even have to be friendly while doing so :wink:

So how do I manually install stock again?

Thank you Ingo!

Your answer leaves me with some confusion, so sorry for keeping asking.

  1. I don’t think a partition got deleted, but the “table” which I understood as some kind of file where the organization of partitions is stored, but as I might most likely be wrong with this assumption: what is the partition table?

  2. Sure, I would need to boot into TWRP to restore or create backups. Is that a problem? That’s how I used to do it on the FP2…

  3. Yeah, I wanted to install the backup via TWRP from another phone - but excluding the system, so “data” should contain the apps. Isn’t that reasonable?
    Thanks for the link!

  4. Right now, I’m not so concerned about the backup, I see that I can do that using other methods than TWRP. But I would appreciate if I got my phone back to being able to use both partitions, which I assume is not the case right now (I had some reason to believe so yesterday, but cannot remember)

1 Like

Not sure if I’m fully qualified to answer all those questions, but here is what I know…

When you write about A and B I think the commonly used name is “slot” not “partition”. Both slots contain multiple partitions, the same for both slots but with different contents. “data” is not duplicated but shared between the slots.

Did the TWRP screen with the two optional boxes look like this?

Wiping Cache and/or Dalvik cache didn’t break anything. So I still think you don’t have a problem that warrants any reinstalling.
IMHO the message FAILED (remote: partition table doesn't exist) might be just misleading and should read FAILED (remote: partition doesn't exist) instead.

With that in mind, my answers to your questions

  1. I think thinking about partition tables is just not relevant, I’d ignore that thought
  2. Yes, but as I wrote you need to boot via adb. Which was my fault, in fact it’s fastboot, sorry. You would need to connect to your PC via USB and execute fastboot boot <path/to/twrp.img> each time you want to boot TWRP, see also How to Boot into Recovery (TWRP/Stock) from Fastboot Mode - DroidWin
    So you cannot just boot into TWRP as before on the FP2 by e.g. pressing Vol-Up while powering up the phone
  3. I have no idea if that’s reasonable, my gut feeling is that it’s “odd” because the FP2 hat a 32-bit CPU and the FP3 has a 64-bit CPU (not saying it doesn’t work, it just feels wrong to my taste)
  4. Not sure what to advise here

Thank you!

Yes, that’s how it looked like, I think I wiped both there.

You’re right, I was talking about slots, not partitions.

Yet, what would it mean that the partition doesn’t exist?

  1. If you suggest to ignore the thought about the partition table, do you think I should still do anything at all? Lineage is indeed working on the phone, but I want to make sure the installation is really right, cause I had to run into weird troubles later on, but now I’m confused again, as I don’t even know how to be sure it is or not :grimacing:

  2. Sure, makes sense

  3. You’re right, I should probably think this through :innocent:

Thank you @AnotherElk!

I should probably have read the “Don’t do these Fairphone 2 thinks on the Fairphone 3!”, would have been smart…

Thanks for the link :slight_smile:

Not sure how to come up with meaningful analogies. But maybe think of it like the headphone jack? Like, you had been used to having one with all of your phones so far but now the FP4 no longer has one.

In the same sense you were used to flash TWRP to the recovery partition with the FP2 (and probably other phones before) but now the FP3 does not have one anymore.

1 Like

Ok, sorry, I guess I got what happend (which is maybe what you tried to explain to me): I never flashed TWRP to my phone, but only booted into using fastboot. This would explain the error message, right?

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.