State of the UBports installer, or command line

To summarise, only 6 lines have to be changed in @Ingo script, to go from devel to OTA-7 :slight_smile:

1 Like

Quick and dirty … I did the fastboot and adb stuff from the script on Windows with manually rebooting the phone between steps … and it worked.
Now how easy was that?
(Now I only need time to play around with UBports.)

Thank you so much for taking the time to figure this out.
KISS principle at its best :slight_smile: .

1 Like

@AnotherElk are you trying devel or stable ? :slight_smile:

devel, with no SIM card at the moment (it runs on my “spare parts” :slight_smile: ).

Could you please write the list of commands you ran, so that the next can save up time?

  • Connect the phone to your computer via USB and boot it into Fastboot mode
  • Download @Ingo’s flash_ubports_fp2.zip …
  • Extract the contents to a directory where you can find them
  • Open a command line and change into this directory
  • Make sure fastboot devices works at this stage (i.e. doesn’t just return an empty line)
  • Open the file flash_ubports_fp2.sh (the Linux shell script) in a text editor
  • Copy or write every line in the script which begins with “fastboot” into the command line and execute them
    For Windows change every “/” in directory paths to "\"
  • Reboot the phone into recovery mode (should be the UBports recovery then)
  • Copy or write every line in the script which begins with “adb push” into the command line and execute them
    For Windows change every “/” in directory paths to "\"
  • Execute adb reboot recovery
  • The phone should reboot and install UBports then.

Done (if no errors come up).


Thank you. At the end I used the script from Ingo, that I did not see, and it worked fine.


Dear Ingo and AnotherElk,
thank you so so so MUCH!

I only recently got my new Fairphone 2, my very first smartphone!

I knew I wanted Ubuntu Touch but it was quite a hassle to try with the installer.
Thanks to your instructions I was able to flash my FP2 with Ubuntu Touch.
It works like a charm. I am very happy :slight_smile:

Only made this account to be able to thank you :slight_smile:


Wow, BusyBeaver, registering just to say thanks is very nice and much appreciated :slight_smile:


Just to point out : this file has to be changed as well if we want to adapt your script to OTA-7 :slight_smile:

Here is the content of the file I found in ~/.cache/ubports/commandfile/ubuntu_commandFP25642 :

format system
load_keyring image-master.tar.xz image-master.tar.xz.asc
load_keyring image-signing.tar.xz image-signing.tar.xz.asc
mount system
update ubports-c34db5ecd943e8c6d003bb96d8825dfb06ebabe510f9d55b4467c944019afdd6.tar.xz ubports-c34db5ecd943e8c6d003bb96d8825dfb06ebabe510f9d55b4467c944019afdd6.tar.xz.asc
update device-9bd5166032690abaefde7030ec186b79a1ad9a677d38382c6346422bd8875dc7.tar.xz device-9bd5166032690abaefde7030ec186b79a1ad9a677d38382c6346422bd8875dc7.tar.xz.asc
update keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz.asc
update version-5.tar.xz version-5.tar.xz.asc
unmount system

I created a ZIP file for OTA 7 (this one ALWAYS performs a wipe!)



Thanks to @Ingo’s ZIP (it was needed as I ran in the same “FAILED (remote: bootimage: imcomplete or not signed)” error as @AnotherElk mentioned in the first post) and @AnotherElk 's tipps for installation under windows I’ve now successfully installed Ubuntu 16.04 (OTA-7) :slight_smile:

In case someone wants the complete list of current windows commands:

fastboot flash recovery .\images\recovery-FP2.img
fastboot flash splash .\images\splash-FP2.img
echo “Please reboot to recovery now”
echo “Pushing 13 files to the phone to prepare installation”
adb push .\images\ubports-c34db5ecd943e8c6d003bb96d8825dfb06ebabe510f9d55b4467c944019afdd6.tar.xz /cache/recovery/
adb push .\images\ubports-c34db5ecd943e8c6d003bb96d8825dfb06ebabe510f9d55b4467c944019afdd6.tar.xz.asc /cache/recovery/
adb push .\images\device-9bd5166032690abaefde7030ec186b79a1ad9a677d38382c6346422bd8875dc7.tar.xz /cache/recovery/
adb push .\images\device-9bd5166032690abaefde7030ec186b79a1ad9a677d38382c6346422bd8875dc7.tar.xz.asc /cache/recovery/
adb push .\images\keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz /cache/recovery/
adb push .\images\keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz.asc /cache/recovery/
adb push .\images\version-5.tar.xz /cache/recovery/
adb push .\images\version-5.tar.xz.asc /cache/recovery/
adb push .\images\image-master.tar.xz /cache/recovery/
adb push .\images\image-master.tar.xz.asc /cache/recovery/
adb push .\images\image-signing.tar.xz /cache/recovery/
adb push .\images\image-signing.tar.xz.asc /cache/recovery/
adb push .\images\ubuntu_command /cache/recovery/
echo “Rebooting to recovery now to start the actual installation”
adb reboot recovery

1 Like

@Ingo Thank you very much for your script. Actually this seems the only way of getting UT to the Fairphone.

1 Like

Looks like manual installation instructions are coming …


They are now available on the device pages, e.g. https://devices.ubuntu-touch.io/device/FP2


That’s not the fault of the command line, wget is just not part of the default Windows command line outfit of commands, but you can easily add it …


1 Like

Ah, Windows… I guess sha256sum needs to be installed, too, then.

If I was to guess I’d assume the Ubports Windows instructions are not really tested. They are 100% identical to the linux commands. I doubt this would work.

1 Like

Yeah, this needs some work. There are also some “sudo” lines which make no sense on Windows, and they copied the “fastboot oem unlock” stuff over from other devices, which is unnecessary on the Fairphone 2.

But I’m so glad these manual instructions even exist now, those hiccups will get straightened out somehow.

When I have some time, I’ll have a look whether something can be done about this on GitHub or wherever.


If it was only that :slight_smile:
I just trial-and-errored my way through the sha256sum.exe for Windows and the Windows cmd … Long story short:

Example which will not work on Windows (from the current UBports manual instructions):
echo "534cc2da2add4a2bd8136b01069ed7dbe432076659fd4780910b6910b916f77b recovery.img" | sha256sum -c

… would have to be changed into this to work on Windows:
(echo 534cc2da2add4a2bd8136b01069ed7dbe432076659fd4780910b6910b916f77b *recovery.img && echo.) | sha256sum -c

  • sha256sum on Windows needs a line break following the checksum and the file to check, else sha256sum will complain about “standard input: no properly formatted SHA256 checksum lines found”.
    echo. (including the dot) takes care of this.
  • To include the line break into what gets piped to sha256sum, the output of the two echo commands has to be joined using parentheses.
  • An asterisk is needed in front of the file to check, else the check will fail.

Edit: Issue on GitHub … https://github.com/ubports/devices.ubuntu-touch.io/issues/18

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.