Starting Fennec causes FP2 reboot


It appears that staring Fennec causes my wife’s Fairphone 2 to reboot. Her phone’s running LineageOS, and I can provide version numbers for Fennec and Lineage when she gets back. This reboot problem started this morning after she updated Fennec via F-Droid. She has the phone with her now, and Icecat browser seems to work fine.

Anyone else had a similar problem?

My flatmate has similar issues. She also uses a FP2 with latest LineageOS (microG Version) installed. When opening certain Webpages, her Fairphone freezes. I’m not sure whether the whole phone restarts or if just the UI restarts, but she is definitely having some trouble using Fennec.

I’m facing the exactly same problem for some weeks now. The phone restarts by solely opening Fennec. My Setup is the same: LineageOS (15.1) with MicroG. Other forks of Firefox are working.

The problem seems to be existing at least since Oct. 14th, because that’s the date I’ve installed IceCat :wink:. I’ve made every update of Fennec since then, but none of the new versions solved the problem yet.

No problems on my side with Fennec 83.1.0 on Lineage for microG 17.1. And I had no problem on Lineage 16 until a few weeks ago.
@jkepler if the problems occurred after the last update, maybe your wife could try to come back to the one before. In F-Droid, go all the way down in “versions” and choose the one that she had before.

1 Like

Same issue here. I could trace it down to any app that would take a large amount of RAM, not only Fennec: NewPipe, AntennaPod, OsmAnd~… The same FP2 runs well with Fairphone OS 19.11. There is definitely something about Lineage OS that makes a difference:

  • does it take more RAM overall?
  • could the daemon-that-kill-processes-that-take-too-much-RAM kill the process of a system app, leading to the reboot?
  • is it just the system lagging, and when this happens, Lineage OS reboots because it thinks it is stuck?

I have tried collecting data about it, but it produced such a large directory that I don’t know where to start the investigation from.

I would like to go back to Fairphone OS because of this, but that would be no less frustrating given the number of apps I use that do not support Android 7. I cannot wait for Fairphone OS with Android 9…

You might switch to /e/OS. There’s an Android 10 version.

1 Like

And there I tried. /e/ OS is sweet, so far it was full of good surprises, but my Fairphone 2 still reboots. For instance I started watching a video of more than 1 hour with NewPipe, and it rebooted.

And I can confirm again that with Fairphone Open: no reboot!

Well, if you’re interested (and it may be worth now, that you’re trying different OSes anyway), you might try out FPOS Android 9 beta too (well, it’s still in Beta so you may face other bugs/problems).

I would like to, so yesterday I sent a request to participate to the beta.
In the meantime I tried to compile it from source, but it turns out I do not have enough disk space!
If someone has access to a built system image, I am interested.

Do you want to try out FP Open OS or FPOS?

The Fairphone Open OS.

I’ve added you to the beta group now.
But if I’m right there’s only an official beta of FPOS up to now.

Thanks ! That will certainly do.

1 Like

I also might give you a self built FPOOS version if needed. But I did the build in November - so it wouldn’t be the latest version anyway…

Thanks, maybe next beta release, then?

Running Fairphone 2 with Open, lastest release of Android 9.
Fennec still occationally crashes and and forces the phone to restart. It is reproducible, but only happens occationally, I’d say 1 out of 3-4 app starts.
I first uninstalled all add-ons, no change, the removed Fennec and am using Duckduckgo no. It’s only second best in my opinion but better than a crashing browser. In my opinion a bug in Fennec.

Actually, I think it is connected to MicroG somehow. Using a LineageOS with GAPPS doesn’t cause the reboots. Also, I fiddled around a little and figured out that the crashes of Fennec only occur with an active internet connection (mobile data or wifi). But please be careful trying that yourself. After starting Fennec in flight mode, I deactivated flight mode a minute or so later. The phone rebooted instantly. After the phone startet it seemed like Fennec is automatically started in background as well. Then the phone rebooted again. I had some kind of boot loop. I solved it by entering my SIM pin and activating flight mode very fastly and then uninstalling Fennec.

All recent updates of Fennec didn’t solve the problem for me until now.

Btw: I’m not using IceCat anymore as it seems to have been removed from F-Droid Repo and doesn’t receive any updates anymore. @DietmarP I tried DuckDuckGo as well, but for me that browser has some quite annoying features. Im going with SmartCookieWeb browser from F-Droid for now, it has similar features like Fennec.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.