Spotify fails to run on Divestos, FP3

Hello together,
is there anything I can do to run Spotify on DivestOS? It fails for me on every start (just closes, no error message). Spotify was installed from aurora store and in a second approach (just to make sure, the apk is valid) I used a apk extracted from my daughters phone. I know, this is related to the google framework. However I cannot figure out, what I am missing.

Some weeks ago, I decided to switch from LineageOS to DivestOS.
On LineageOS, Spotify worked well, thought I had no google apps installed.
Any help is appreciated.

Best regards
Friedhelm

On LineageOS,

DivestOS is the only modern aftermarket OS that explicitly removes the Google Widevine DRM.

In the case it isn’t DRM related you can try the compatibility steps here: Faq - DivestOS Mobile

Thank you for your reply.
With respect: may be, I am kind of blocked in understanding, I cannot find any answer to my question (is there anything I can do to run Spotify on DivestOS?) in your reply.

I expected something like:
Oh yes, I use Spotify on DivestOS. It is possible
or
Oh yes, I did it by installing xyz.
or
Sorry dear, lots of people tried this without success.



Perhaps you can explain a little bit more?
Regards Friedhelm

Widevine DRM is a proprietary Digital Rights Management (DRM) library by Google, which can be used by Apps to enforce copyright on content using various cryptographic methods and other checks. So basically if an app uses this to restrict content and you don’t have that piece of software published by google you won’t be able to play that content.

So what @SkewedZeppelin is saying is, that assuming that the official Spotify app uses this DRM system (which it seems they do) your issue could be related to that, since Widevine DRM is not present on your system.

3 Likes

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.