"Sounds keeps stopping" message; can't change Ringtone or other Notification sounds

Welcome to the community :wave:

I’ve moved your post to this existing topic.
Try clearing the cache of the Sounds app first, if that doesn’t help you might have to use the more complicated fix right at the end of the thread.

1 Like

I tried emptying the cache already, but to no avail. I’ll try adb shell !

Edit : I’m following the guide, but I’m completely lost when trying to install the drivers.

Not a Windows user myself, but let’s see if we can’t figure this out :slightly_smiling_face:

Try downloading this driver and follow these instructions.
Let me know where you get stuck in the process :thinking:


I tried that too. I just get a message that tells me that I already have the most up to date drivers

That sounds like you should be all set on the driver side.
At what point of the process do you have issues, what exactly isn’t working? :thinking:

I remember when I was installing ADB the main obstacle was with the Windows drivers. I got everything working by going to Windows Settings (Home) > Update and Security

View all optional updates
and then, if there’s an option mentioning Android, tick the box and click “Download and install”.
You’ll want to reboot the PC.


Thanks ! Now when I type “adb devices” it recognizes it !

Okay so, I’m following the guide above, but when I type the “adb shell settings put system ringtone” I just get “canonical isn’t recognized as an internal command” (something like that, my PC is in French). But at the same time it seems to be working, because now my ringtone is '“Draco” and not “cut_temp.wav” and when I try to select a ringtone it doesn’t crash. So it works, finally \o/ Thanks to you two !