Some QR scanners not working with lineage 15.1

A few weeks ago I made the switch to lineage 15.1 - and couldn’t be happier. Except: there are some barcode scanner apps that aren’t working anymore but that used to work with lineage 14.1 and FPOS Android 6 and 7. It’s roughly 50% of the scanner apps I tried, e.g. “Trend Micro QR scanner” and “Free QR scanner” by “EZ to use”. The other 50%, including the camera app, are working just fine. Googling didn’t reveal any connection between lineage 15.1 and non working QR scanners, so I figured maybe it’s FP2 specific. Can anyone reproduce these issues, or tell me they are working for them?


Maybe some not-so-privacy-friendly QR scanners rely on Google Framework for easy data connection that is not necessary to provide QR scanner functionality? I suggest a simple QR Scanner like app with same name from SecUSo available on F-Droid.

1 Like

Thanks for your reply! Let me provide a bit more context:
I’m using LOS with the entire Google shebang, i.e. the “full” gapps, so I guess privacy-friendliness is gone anyway.
Unfortunately using other scanner apps is not going to solve my underlying issue, which is that the QR scanner in my banking app is among the ones that don’t work. When I tried to narrow down where the problem is I found that many QR scanning apps, but not all, are not working.
If anyone uses LOS 15.1 and finds that the apps mentioned above are working for them, then I have some hope that the issue is fixable. Otherwise I guess I can live with the situation. And for what it’s worth: I still have the original camera.

What you mean with “don’t work”? No access to camera? Does not open web browser? Crashes on start? Again: The app “QR Scanner” from SecUSo is working fine with LOS 15.1.

The SecUSo app is indeed working nicely, thanks for that hint! Unfortunately, however, I can’t plug it into my banking software. :slight_smile:
“Not working” means that everything looks all right but the scanner doesn’t find a QR / barcode. I.e. “working” apps just have to have the code somewhere close to the camera and not even perfectly focused and then display the result, whereas non-working apps can have the code perfectly focused, not moving the slightest bit and filling the scanning area completely and still won’t detect it. Such apps that can look for a code in an image will fail saying “no code found” - leaving me puzzled…

I have exactly the same behaviour and problem. No gapps in my case, I have the microg fork version.

But is the same issue my banking app cant detect the barcode. Camera starts fine but never detects a code.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.