Some apps shut down after running few seconds

Hi fellow fairphone users!

I’ve been a happy user of fairphone 1 for +2 years now. A while ago I’ve noticed a weird bug were Messenger app was shutting down after 10-20 seconds as I was typing a message. I have tried uninstalling and reinstalling the app, but to no avail.
Annoying, but not a major issue. However recently I’ve started noticing the same behaving with the Firefox app, that is my main browser. Now being forced into using a different browser IS seriously annoying. Obviously uninstalling and reinstalling didn’t help.
So I’m wondering: does anyone have any idea of how to solve (possibly) both issues?
Is there any repair routine I can try or am I condemned to live with the problem?
Any help will be highly appreciated!



Can not say, that I had any problems like that.
Firefox workes just fine for me, even the nightly version.
Maybe you have to do a #dic:hardreset.
But maybe someone from the technically more apt users here has some ideas, before you have to take this road.
Keep my fingers crossed for you.

I sometimes get this type of behaviour when there are too many apps running in the background. The FP1 only has 1 GB of RAM memory, and apps appear to be both increasingly memory hungry and insistent on running in the background from the moment the phone starts. Restarting usually helps for a bit, uninstalling apps that I don’t use anymore stretches that a bit further (as quite a few will still start themselves silently without me ever touching them).
Also: firefox uses more memory depending on the number of tabs and what’s open in them. Having about five tumblr archive pages open at the same time used to be a sure-fire way of crashing firefox, though newer versions seem to happily unload a bunch of them to avoid this. Your mileage may vary.


Thanks for the information!
If I look into the running apps, I have around 180MB free, which I would assume it should be enough for running 1 single tab on firefox?
Maybe before doing anything drastic I should also ask FP support and get their thoughts on this…

Have you tried cleaning the cache of the apps?
Might help,.

I think I did try this when I was troubleshooting the problem. I have also unistalled and reinstall the app altogether, but to no avail… :frowning:

Instead of Firefox I can recommend Lightning.

@Lidwien As pointed out here (in German) Lightning uses the old browsing engine on FP1 and is thus insecure - just like the preinstalled Browser app.*

You could try clearing the cache of all apps. To do so go to Settings > Storage > Cache and click “ok” when prompted. This will clear the caches of all apps, but keep all important personal data.

Further, I can recommend the app Autostarts, available from the F-Droid Archive. This app will enable you to disable apps from starting in the background and using up processing time and memory (and might even increase your battery time a bit).

* For more info see ✏ Constructive tips for improved security for the FP1(U)

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.