Some apps not working on FPOOS 9 & 10 (Klett Augmented, Phase 6)

Hi,

after some years of successful operation of my FP2 on FP Open OS, now I see some trouble. Previously I did not have much issues with the lack of the Google Play Services. Accuweather complained about that, MVG Fahrinfo too, but ran nonetheless. For the Corona Warn App there is an apt fork (Corona Contact Tracing Germany).

But now I ran into some trouble at an unexpected point: Learning software…

The German publishing house Klett, mostly renowned for it’s language learning publications, has an app called “Klett Augmented”. And another for studying vocabulary, called “Phase 6”.

They are from different software companies, but the share the same development target (SDK 30) and they show the same problem:

You can install them, start them. But then - nothing happens. Klett Augmented should display a camera image, as the app is used to take a picture of a learning book’s page to play the audio files for that particular page. But no camera image appears (permissions to use the camera are of course granted upon install), only a waiting indicator (circle being refreshed), and after some seconds, the app complains about incorrectly aligned page photo…

Phase 6, after selecting whether you’re pupil or adult, should offer you a selection of language or publishing house, but it too only displays a waiting indicator (horizontal line being refreshed).

At first I thought it might be because I procrastinated upgrading from Android 9 equivalent to A10, which the FP Updater proposed for months. So I did upgrade to the latest relase of 10, but the problem remains…

Thanks for any help

hman

Just a guess: which camera app are you using as the default camera app?

1 Like

Normally I use Open Camera. Never thought this could be an issue. Other software (SecScanQR and CCTG) call on the camera with no problems. I’ll give it a try and re-enable standard camera, thanks.

1 Like

That’s not the source of the problem. After re-activating standard camera, Klett Augmented still doesn’t show a camera image. Phase 6 does not make any use of the camera in the first place (isn’t supposed to use the camera, it’s an online lookup service). And to be sure that Klett Augmented really took note of the fact standard camera got available, I deleted and re-installed the app. To no avail…

Did you reboot after changing the default app?

Now I did. No effect :frowning:

Update: Klett Augmented changed it’s mind and now works. The only thing I can remember to have changed is that I changed the APN of my network (E-Plus/O2/Telefonica) from E-Plus to O2.

Phase 6 also changed some things. While the start screen still only shows a “sandclock” visual (horizontal line constantly refreshing) it DOES talk to its base. Meaning: If you log into Phase 6 via the link that Klett publishes in their books (klett-sprachen.de/phase6) and then add the free-of-charge test version of a vocabular package, that DOES show up in the phase 6 app and works (vocabulary can be trained, including audio) and training results get reflected on the web interface.

So far I could not get the app to show the 9,99€ paid package I just purchased. Could be because payment might see a delay of 1-3 days. But the web interface now shows I have a paid package, while the app doesn’t.

One annoying thing, and this would definitely be a compatibility issue of FPOOS on Android level 10:

Constantly, repeatedly, an error message is displayed as an overlay over the app:

“Developer warning for package de.phase6.freeversion.beta. Failed to post notification on channel “null”. See log for details.”

Buttons do work even if covered by the error message, but you can’t read whats written on them, so button pressing must be done blindly.

Created a separate report on the error message display.