English

[SOLVED] Where to find boot.img for LineageOS with MicroG for Fairphone 3?

Hello,

For my Fairphone 3, I’ve been using LineageOS 17.1 with MicroG (the one with MicroG integrated from here) plus Magisk successfully for a while.

However, today I updated to the latest 20210706 release of LineageOS with MicroG via the builtin system updater. And I see that I need to re-install Magisk, too.

The Magisk instructions say that I need to use the Magisk app to patch the boot.img for my operating system. I already have the Magisk app installed, but where do I find the boot.img for my system???

I looked into the lineage-17.1-20210706-microG-FP3.zip file, but it does not contain boot.img. Where else can I might boot.img?

Thanks.

P.S. The LineageOS with MicroG .zip file for the Fairphone 2 includes a boot.img, but not the one for Fairphone 3. Why is that??

After unzipping you will see a file named payload.bin. This file contains the boot image. You’ll need a payload extractor/dumper to dump its content. The payload from LOS4MicroG contains boot, dtbo, system, vbmeta and vendor.
See this for additional information: Extracting proprietary blobs from LineageOS zip files | LineageOS Wiki

3 Likes

This worked, thank you!!!

A bit frustrating that I’ll have to do this every time my LineageOS gets an OTA update, though. :sweat_smile:

For updating you may try this (/e/OS is partly based on LineageOS for microG)

(If you don’t have TWRP you can skip that step, of course.)

1 Like

Thanks @bege. The instructions you linked to refers to flashing Magisk from a .zip file, but the recent Magisk releases only seem to have .apk files. Is there some place else to obtain the .zip files??

Please read the magisk installation instructions carefully, you just need to rename the file to .zip

3 Likes

Thank you! Didn’t even know that page existed.

Your question has been answered by yvmuell already.
But I linked that post because the second part is about updating the system without the need to flash Magisk again.

1 Like