[SOLVED] Update from LineageOS 17.1 to 18.1

Preface: LineageOS on our FP3 was installed following this guide. Active Slot is “a” containing LOS 17.1 20210726 and slot “b” should contain LOS from late June.

I followed this guide and everything worked up to point 6. I tried to sideload the opengapps package (open_gapps-arm64-11.0-pico-20210825.zip) which immediately fails.

The recovery console on the phone shows “timed out waiting for fuse to be ready”. After rebooting into recovery mode again (EDIT TO ADD: I re-read the guide and this is expected - my bad) sideloading opengapps is possible but fails (correctly) because slot “a” still contains Android 10.

Rebooting to system leads to a normal working installation in slot “a” (LOS 17.1)

My questions:

  1. Did the sideloading of LOS 18.1 work or not (since the active slot was unchanged)?
    (EDIT TO ADD: Solved: What does the error message mean?)
  2. Is the upgrade guide correct?

In a slight panic I had rebooted to revovery via “adb reboot recovery” - which does not change the active slot.

The guide is correct and has to be followed exactly as written :wink: .


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.