[solved] Problems receiving SMS in South Korea (prepaid provider: EG SIM)

Hello everybody,
I’m using the Fairphone 1 in South Korea with a prepaid SIM (Provider: EG SIM). I’m experiencing strange problems with receiving SMS. I reveice some SMS just fine, but with other I get “Message size 1KB Expires: Date” instead if the message, with a “Download” button appearing next to the message. When I click it, it says: "Download of Message … from Contact Name was unsuccessful."
Receiving SMS with Korean characters is not the problem. It’s not like some SMS from one person are sometimes properly delivered and sometimes not; from some contacts my Fairphone seems to be unable to receive the messages.
These problems occured since I moved to Korea and used my new Korean SIM card.
Has anyone an Idea how to figure out what the problem is?

I’m only aware of download buttons when an MMS is received. It may be that some of your contacts are sending MMS messages by default, which would explain why this is contact specific. For MMS reception you need a working mobile data connection with your service provider (i.e. Wifi won’t work - in some cases people have even had to disable their wifi connection to force a data connection). If you’re using both SIM slots, you’ll need to make sure the data connection is on the SIM that corresponds to the number on which you’re trying to receive messages.

Edit: You also may need to check the APN settings for your SIM. If I’m not mistaken, your provider lists instructions here (step 6).


Thank you already! This sounds reasonable.
I had set the APN according to guide provided by EG SIM. I just checked the setting; I didn’t set any MMS port as there was no information on this in the EG SIM guide (also not in that you have send me the link) - so it says “MMS port: not set”. How do I know which port to set in the APN?

Good question - maybe if they don’t specify one, it isn’t required for their network? Unfortunately I’m not an expert on the technical details of APNs. If there is only one access point associated with the EG SIM, it may be worth creating a second one with the same details, except for ‘APN type’ , which takes the value mms (rather than default). This is based on the troubleshooting section from my own provider, which mentions that in android >4.0 mms needs to be defined in a separate APN. Hope this works, if not, your SIM provider maybe better able to help.

1 Like

I only found those APN details

However I have solved the problem. When setting the APN i had to click on “APN type” and in addition to “default” also check “mms”. Now I “download” als the SMS I’ve received.
Thank you very much for your help!


This topic was automatically closed after 5 days. New replies are no longer allowed.