[Solved] Problem to unlock device via fastboot on FP4

I have tried several times to unlock my FP4 to install eOS via adb and fastboot.
adb detects my device which is identified via :

$adb devices
List of devices attached
[number] device

But when I do :

$fastboot flashing unlock
< waiting for any device >

I wait, I wait, I wait, and nothing happens.

On FP4:
remains hopelessly displayed.

does anyone have an idea ?

Ubuntu 20.04.4 LTS

Are you in fastboot mode? If it’s detected via adb then it’s not in fastboot mode. Run adb rebooot bootloader to reboot into fastboot mode.

Otherwise fastboot is also a bit picky with USB cables. Try a shorter / better quality USB-C cable if you still have problems.

You can also list fastboot devices via fastboot devices.

1 Like

If adb displays the device but fastboot doesn’t, in my experience it means you should try another cable (as xblax suggested).

this is exactly mentioned very often in several boards…

Often, the problem is:

  1. the USB Cable (somteimes because of C-C instaed of A-C)
  2. the USB port ot the PC/laptop

it works well for adb devices but not for fastboot devices and data transfer

try to change the cable or USB port.

1 Like

I am just guessing here but could it be that the command demands “sudo” ?

1 Like

the commands for itself not.

1 Like

However reading this…

1 Like

I agree, this needs sudo if the correct udev rules aren’t installed.
Either use sudo or:

1 Like

in linux, the android-sdk-common packet should set the udev rules, so that sudo is not needed.
in theory…

I think I am in fastboot mode but I don’t know.
I unlock EOM. USB debug enabled.
I restart my FP4, unlock screen (“Fairphone 4 5G” appear in Dolphin)
When I do : $adb reboot bootloader, the phone reboot (connection seem ok) and display a screen where “FastBoot Mode” is in red and another red line below “DEVICE STATE - locked”
“adb devices” command list no devices attached.

Your phone is in Fastboot Mode, yes.

What is the output of sudo fastboot devices? (adb is only for managing the phone in other states)

the command gets nothing

Ok, so sudo permissions are probably not your only problem.

Try using a different USB cable / port as @xblax suggested and see if you can get the device to show up.

sudo fastboot devices gets nothing

once again. change cable and/or USB port.

adb reboot bootloader restart FP4, I think the Cable/port is ok. No ?

That’s very much the case, just because it works with adb doesn’t necessarily mean fastboot will “like” your cable.

1 Like

android-udev-rules is installed.

$adb devices                                                                                                
List of devices attached
* daemon not running; starting now at tcp:5037
* daemon started successfully
[number]        device

but fastboot device still gets nothing

I only have 2 usb C cables and I doubt that it comes from the cables that work well with other devices when I exchange data…

once again. change cable and/or USB port.