[Solved] Fingerprint sensor completely dead after software update

Edit: I panicked, went to open a support ticket for FP4, and read that maybe Safe Mode could fix the problem. I rebooted into SM, the sensor was working ok, rebooted in normal mode again, and it’s working again. I have no idea what might have happened.

Today I rebooted my Fairphone 4 and this materialized a software update that somehow was pending (I was not aware of it, nor do I remember when was the last time I had turned it off). As a result, the fingerprint sensor has stopped working: my finger is still saved in the phone, but the sensor will just not reach. This means that I can’t access some critical banking features.

The phone has been working perfectly fine for half a year, until today.

How can I debug or troubleshoot this issue myself?

2 Likes

Hi astrojuanlu and welcome to the community forum.

Don’t worry, the best questions are those that come with their own answers :wink:

Glad it’s working again!

1 Like

Hi astrojuanlu,

Thanks for sharing this unpleasant experience.
Glad that it works again.

1 Like

TL; DR : restart your phone once more after migrating to Android 12 !

Exact same issue here : after installing this exact same system update, I was surprised to notice that my fingerprint sensor is not working anymore :disappointed_relieved:
It wouldn’t unlock the phone, or even vibrate when I press my finger …
A single “regular” restart of the phone and now it works again !
A bit frightening, but really not that serious in the end :yum:

1 Like