[Solved] Fastboot -w installing /e/ with Linux, Fedora on Fairphone 3

The picture I made earlier:


I haven’t made a new picture, but now the picture is showing
DEVICE STATE - unlocked

I run on the pc: adb devices

daemon not running; starting now at tcp:5037
daemon started successfully
List of devices attached
A209xxxxxxx device

[lidwien@Tux platform-tools]$ adb reboot bootloader

The device reboot automatically. It will show a warning. Press Volume + or Volume - to display boot options, select fastboot and confirm with Power to reboot on fastboot
I did choose ‘fastboot’

And I get the above mentioned picture.
(In my computer the cursor is in the map where I have downloaded /e/ to and I have unzipped it there. And I am root now)
I type:
[root@Tux platform-tools]# fastboot -w

and I get:

/usr/bin/mke2fs failed with status 1
fastboot: error: Cannot generate image for userdata

Can anybody help?

One option when do a search is to type only ‘fastboot’.
Thus leave the -w away.
I don’t know what will happen if I do that, so I don’t know if that is safe to do.

This command should reboot the phone to Fastboot Mode (aka bootloader), and it seems that in the end you are getting there.
Edit: I don’t get an extra screen when I do this, I get Fastboot Mode directly. Perhaps connected to the following? …

Known fault of the fastboot command some Linux distributions would install for you, and observed on macOS, too.
Please make sure to use the current Android SDK Platform Tools.

On Windows that will output fastboot: usage: no command … fastboot needs a command apart from itself to know what to do.

1 Like

I never used Android SDK Platform tools before. I did install it.
So I don’t know how to use it.
Do you know where I can find how to install /e/ by using Android SDK Platform tools?

I had same problem.
I have installed adb & fastboot using apt install commands.
Each time I tried to send Fastboot -w I had error with mke2fs…
Someone help me on /e/ community. He explained me to install the Android SDK Platform Tools.
Just download the zip file then extract it.
In your home folder, locate the file ~/.profile and add this at then end :

if [ -d “$HOME/place where is the folder/platform-tools” ] ; then
export PATH="$HOME/place where is the folder/platform-tools:$PATH"

Close your session, open it again and in my case, no more error with Flashboot -w.

Hope it will works for you…

1 Like

Yes, I know this page. But I have problems with Android Studio.
My ‘platform tools’ are in a different place, the map ‘adb-fastboot’ .
Perhaps it means removing adb-fastboot and re-installing Android Studio to get ‘platform tools’ in the right place.

For simplicity’s sake you could unzip the platform tools into a folder, then unzip the install files for /e/ into the same folder, then cd into that folder and run the commands to install /e/ in this folder … perhaps as root or with sudo.

1 Like

The link to download the platform here

Extract zip file in a folder then modify your ~/.profile.

This was exactly what I did. And that gave me the problem with fastboot-w.

That’s the one I uses after the problem with platform-tools which are in the map adb-fastboot.
So I better erase adb-fastboot and erase and install Android Studio.

1 Like

Then you could precede every fastboot command with ./ so that Linux has no other idea than to use the one in the current path.

When you are in the path with all the files, compare the output of fastboot --version and ./fastboot --version to see whether there’s a difference in where the fastboot command comes from.

1 Like

Did you have to make a new project in SDK?

Yes, this works! Now I can start installing /e/.

Thank you all for your help.
On Fedora you have to do everything as root and in the final steps of installing /e/ one need to start the command with ./ For example: ./fastboot -w
./fastboot flash system system.img
and so on.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.