[Solved] Fastboot oem unlock problem, installing /e/ with Linux, Fedora

On my pc screen it shows:
adb devices

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    List of devices attached
    A209xxxxxxxx device

So I do:
fastboot oem unlock 6bxxxxxx

and I get on the pc screen:
< waiting for any device >

and my phone is showing the following picture

Can anybody tell me what I have to do get the command ‘fastboot oem unlock 6bxxxxxx’ work?

Now I see on the screen of the phone:

This is strange as I unlocked the phone yesterday.
I think at switching the phone on and off yesterday after unlocking, made the phone forget that it was unlocked.
So now I will unlock the phone in developer options again.

I think simply ‘fastboot oem unlock’ should work? Maybe you need to run it as root, I’m not sure.


What exactly did you do yesterday? Was that some development option (“OEM unlocking”) in the settings app?

In that case you didn’t unlock the phone. Just allowed the phone to be unlocked.

Depending on your version of fastboot, the correct command might be fastboot flashing unlock.
Try fastboot --help and look for the unlock example.

@robbert.f was right. I needed to do it as root.
I am running Linux, Fedora and then one isn’t used to work as root.


15 posts were merged into an existing topic: Fastboot -w installing /e/ with Linux, Fedora on Fairphone 3

Thank you all for your help.
On Fedora you have to do everything as root
and in the final steps of installing /e/ one need to start the command with ./
For example: ./fastboot -w
./fastboot flash system system.img
and so on.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.