[solved] FAILED (remote: 'Partition flashing is not allowed')

Hi all,

Just wanted to make a quick post about an issue I just had and how I solved it.

So I installed e/OS/ and due to unrelated issues I had to go back to stock Android. I followed this guide: https://support.fairphone.com/hc/en-us/articles/18896094650513-Installing-Fairphone-OS-Manually, flashing with fastboot

Then, when executing the .bat I got this error message:


Removing the battery didn’t work, so I looked online and the issue is fixed by executing the “fastboot flashing unlock” command

For that you need fastboot installed… But if you followed the guide you already have it! Just open a command prompt inside the downloaded folder “bin-msys” subfolder, and you can execute the command:


I hope this helps!

1 Like

This command actually is part of the guide you linked to, in “Follow all the steps in the article Manage the Bootloader to unlock your bootloader.

I see a possible problem for Linux users in that a big bold header there says “Part 2: On your computer (Windows and macOS)”, while this part applies to Linux, too, and clearly says so in the text. (@anna_jopp : This seems to need fixing?)

Could this have been the issue here?

.bat is the file extension for Windows batch scripts and the terminal looks like Windows command prompt, so likely not due to the minor Linux misinformation.

1 Like

Good point, I was too quick to go by the “$” prompt and the use of “./” in the second screenshot, which would be unusual on Windows, but the first screenshot clearly says “MinGW on Windows” :see_no_evil: .

1 Like

Hi there,

Sorry if the post wasn’t clear, I just wanted to point out that the required tools (adb, fastboot, etc) are already downloaded in that specific scenario, in case someone installed e/OS and afterwards moved back to stock.

Thanks for your time!

You could edit the topic title in this case (pen icon right beside it) … unnecessary tool download etc. something or other :wink: .

1 Like