[Solved] DNS error with specific SIM on certain servers

Hello, I have a small problem when using mobile data. I’m located in the Netherlands, and have a FP3 running the latest standard version. I have two SIM cards, one from T-mobile, the other is KPN. With the KPN one I cannot access data for two apps as far as I’ve noticed. It’s a weather app and an app for smart lighting.

Checking the servers they use to get data shows I get a DNS error. It only happens with the KPN SIM. the other one works. I also tried one SIM at a time. Same problem. Then I tried the KPN SIM in a different phone (Motorola Android One) where it actually works… Somehow the SIM-phone combination is causing some stange behaviour. Did any of you see this before? The servers that don’t work for me are: https://windwatch.net/ and api.meethue.com

Just wondering if it is some hidden setting (and which one) that is wrong or if it’s a more general problem. Curious to see if somebody can reproduce this…

Thanks in advance,


Hi Michiel,

I had similar issues after the Android 10 upgrade with Telekom.de in Germany. During the upgrade process, an IPv6 only APN had been set. After manually reverting to Dual Stack (i.e. IPv4+v6), everything worked fine again.

Please check the KPN APN settings on your phone. You can do that under Settings > Network and Internet > Mobile network > Advanced > Access Point Names. The correct values should be somewhere on the KPN website.

Good luck!

Hey Thomas, thanks a lot for that! I’ll try as soon as I can! I’ll let you know if it worked.


Hi again Thomas, I just checked, my phone had the IPv4/IPv6 setting, while the KPN APN settings (for android 9 though) suggest it should be IPv4 only. Anyway, on both settings I keep having this problem. With IPv4 only I don’t get connected at all. The APN settings in the FP3 have more options than the KPN website mentions, so I think I’ll get in touch with them again and check what could be important for this. To be continued…

You do not by chance have something like Netguard or Blokada installed on your phone, do you?

1 Like

No, not that I’m aware of. I do have Norton mobile security installed. I can try if removing that would change anything… But I think I did that some time ago already.

FWIW: I am also using KPN (on my Fairphone 2) and have an IPv4 only APN. KPN appears to offer IPv6 only to select customers with approved phones at the moment, so an IPv4 only APN should be correct for KPN.


Hi Albert, I tried the different IP versions available, but nothing works completely well. Anyway, in the android 10 APN settings, there are some that are not visible on the KPN site, so I will check with their support. They should be able to tell me what settings are important, so I hope that will help.

Thanks for thinking along with me!



The people at KPN couldn’t really help either. Meanwhile I tried to put the KPN SIM in a different phone (Motorola Android One), also a dual SIM phone with Android version 10. No problem there!
There is something funny going on, but cannot get down to what it is really. I did report it to FairPhone support now, so curious to hear what comes from that.

Best again,


I’ve tried again today, it normally isn’t a big issue anyway, and i can work around it normally. It just happens to be solved. Not sure if it’s an FP update, or a change at KPN…



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.