Solved data dropping ("!" near the data icon) with FP4/5 (eOS) in Belgium on Orange network (with Neibo)

This had been met with a Fairphone 4 and a Fairphone 5, both on eOS, in Belgium with the Orange network. Our provider is Neibo, but the instructions to solve the issue come from Orange (Orange France, weirdly).

The issue was: mobile data network going randomly reachable or unreachable. We were indeed sometimes losing data services: the signal would be as high as before, but an exclamation mark “!” would appear aside of the data icon, and internet would not be working properly anymore. Rebooting would not help. Calls and SMS were not impacted.

In order to solve this, you need to create a new APN:

  1. Go to Settings (Paramètres) > Network and Internet (Réseau et Internet) > Internet
  2. Aside of “Neibo” (or the network which is listed with your provider’s name), tap the wheel (roue crantée)
  3. Go all the way down and tap “Access point names” (Noms des points d’accès)
  4. Tap on “+” to create a new one
  5. Enter the following settings to enter, then save the new APN by tapping the “…” and “Save” at the top of the screen).
  6. Go back to “Access point names” (**) screen and select the APN you just created. Issue should be solved.

Settings for the new APN

  • Name: whatever you want (i.e. “Neibo internet mobile”)
  • APN:
  • Proxy, Port, Username, Password, Server, MMSC, MMS proxy, MMS port: leave empty (“Not set”)
  • MCC: 206
    *MNC: 10
  • Authentification type: PAP
  • APN type: default,supl
  • APN protocol: IPv4
  • APN roaming protocol: IPv4
  • APN enable/disable: enabled (greyed)
  • Bearer, MVNO type, MVNO value: leave empty (“Unspecified”, “None”, “Not set”)

What’s the difference with the original APN? Just the addition of ‘,supl’ to APN type? Or was there more?

1 Like

Excellent question. There’s three preset profiles and I didn’t remember which one was selected, and none of their names are related to Neibo: Mobistar*, Telenet, Mobistar MMS. Hopefully, I took some screenshots and it looks like Mobistar was the one selected by default on eOS.

All settings I listed are already set up. The differences are:

  • Proxy + Port: an IP address and port 8080 are set
  • Username + Password are set (both are “mobistar”)

All others settings are the same as it should be, including “default,supl” which is already set.

*Mobistar is the previous name of Orange Belgium’s network.

I’m on Orange BE and I had exactly what you wrote, except for APN type which said ‘default’ instead of ‘default,supl’.
Haven’t had many issues (except when due to bad coverage). But I’ll check my kids’ phones (they complain a lot about their 4G coverage and they are both on Neibo.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.