[Solved] Cannot connect to 5G network after update

Hi there,

this is my first post here. Yesterday I updated my Fairphone 4 to FP4.SP21.B.048.20230215 containing the security patch for February. Anyway since then everytime I connect to 5G network the phone freezes and restarts which makes the 5G basically unusable. Does anyone have any idea?

Hi kivilaan and thanks for joining the community and sharing your problem on the forum.

This problem (and I haven’t seen other reports) is most probably resolved either by Fairphone, or your network operator, or both. Would you mind indicating which operator you are using?

You should definitely #contactsupport and let them know about this. They will advise as to whether you should contact the network operator as well.

Also, are you using a SD (memory expansion) card, and if so, is it formatted as removable or as internal?

1 Like

I’m using Orange Romania. The sim card is like 6 month old and worked fine before.
I do have an sd card with 128GB capacity which is formatted as external storage. Removing it, is not solving the issue. I also tried running in safe mode still the issue continues. Sofar, only limiting to 4G avoids the restart. I will go to my network operator today and see if a new sim card might help.

1 Like

Which carrier do you have?

First thing I would do is check if the APN settings are correct. Maybe they were somehow overriden in the process of the update.

Best wishes,

Just got back from the Orange Service. Indeed some network config was corrupted after the update. They were able to fix the issue within a few minutes. What exactly was done, no idea.

Thanks for all the input!