[Solved] App LibreOffice Viewer crash

on a FP2 using FPOpenOS
I downloaded - from F-Droid - the app “LibreOffice Viewer” to view a .doc file.

It worked one time. Then it crashes all the time (with the same .doc file).
I opened the .doc file either directly from the inbox (K-9 Mail) or after having saved the document into the Download folder (file opened via Amaze file navigator).

I rebooted the phone with no effect on this.

Any idea ?

Go to Settings > Apps > All and clear cache & data of the app.
If that doesn’t help try a different file. If the crash only happens with that one file it may be corrupted.

1 Like

It could simply be that LibreOffice viewer is a very buggy app… I use it to view OpenOffice files and it also crashes very often

I use the LibreOffice Viewer for reading .odt and .docx files without problems on my FP2. I have the “Experimental Mode” for editing text disabled because this doesn’t work stable yet.

@mohican you could try to go to settings and make sure the Experimental Mode is not enabled.

I installed TextMaker Free to open DOCs because I read promising things about the now free SoftMaker Apps, but I’ll admit I didn’t stress it yet with complex documents, I just opened some basic DOCs to see whether it works in general (which it did without crashing).

Edit: Ok, curiosity won :slight_smile:

DOC with tables and embedded images 170 KB … no problem.
DOC with tables and embedded images - mail merge 100 pages 14 MB … no problem.
DOC with tables and embedded photos 150 MB … Android requester to cancel App or wait … I waited … a little slow scrolling, if that counts as a problem :slight_smile:, no problem otherwise.

The overall structure of the documents was preserved correctly, placing of embedded stuff was minimally off here and there, but nothing much to complain about.

XLS with a lot of different tables and VLOOKUPs between them, Hyperlinks and stuff 26 MB … looks and works almost exactly as in Excel … wow :+1:

Don’t have too complicated stuff for that, but
PPT with photos and text 195 MB … no problem.

If in doubt, I would give this set of Apps a try :wink: .


Eventually I realized that by default F-Droid had installed the 5.0 alpha version of LibreOffice Viewer.
I changed it for the latest 5.2
Bug did not come back on my test file.
-> solved
thanks everybody.