Software Update: FP4.FP3S.A.103.20220221

You’ve written a bit more :wink:

Let’s not start a flame war here, okay? :slight_smile: As I said, I know the drawbacks. Don’t worry about me. :wink: And while there are bugs in the stock ROM, I make sure to report everything to the support team so it gets fixed eventually. Custom ROMs have its problems too.


It’s OK. I don’t want bother anyone. Peace :v:guys, there is to much sadness in the world

1 Like

Hi, thanks for this. How does this get pushed to users? Through Google Play or via some other update mechanism?

I just checked and it has not reached my phone yet, although that is a bit premature I agree.


What exactly do you mean by that?
I just took a photo in the apartment with location information and that is very accurate (less than 1m) shown on the map.

Hi, this was already disussed here:

For me it was solved with the last firmware update (January), for others the problem still persists.


Note that any other camera app (or any app that uses location basically) works just fine and manages to get the correct location (even inside my apartment). But location from the stock camera app is off by several hundreds of meters. And it usually “snaps” to one or two fixed locations in my area. It’s possible that those locations are cell towers. But there is absolutely no reason for this behavior. It seems to me that they don’t use Google’s location services but some kind of their own (buggy) solution.

Thank you @Razem for this comprehensive overview! I think it would be a good idea to hand it over to Fairphone support.


If anyone needs it, here’s a link to the

1 Like

Please see this link

1 Like

Weird stuff. Roaming was disabled for me as usual, but WiFi Calling as well as VoLTE both stayed on on both my SIMs. Could it be a network operator default hard-coded into the OS?

Can’t confirm the quick GPS fix… or any fix at the moment… :frowning:

1 Like

Ever since I received this update, I’ve been seeing random crashes of my phone, to the point it is barely usable.

Sometimes it enters a crashloop. Crashes at the blue “Fairphone” logo before I can even unlock the phone. It is late enough to connect to BT headphones and to adb logs.

After few loops like that it exits the crashloop, but then it crashes after few minutes anyway.

I have adb logs from multiple crash instances, but there doesn’t seem to be any pattern. Each time the final log lines are different.

I cannot repro the crashloop in safe mode. I tried to uninstall all apps I don’t absolutely need (I cannot afford uninstalling interrail app at the moment), to no avail.


Does not happen on other phones using a Multi-SIM from the same network operator contract.

I filed a request to support to provide more detailed release notes. They said “we’ll consider it”. So there we have it.


Weird, my phone offered update to the same version you mentioned, but there was only the security patch level. No changes in the list of changes.

Perhaps this is a job for tech support rather than the community. I can definitely say that the update did not have this effect for me. It should be unlikely, but maybe something got corrupted in the process. Did you root your phone? If so, did you make any modifications?
Generic things you could try are a manual installation from a host computer using USB and the adb tool… or maybe a full factory reset. The latter is a rather nuclear option and depending on how much apps and data you’ve got stored on your phone could definitely take a good chunk of time. Sorry I don’t have more targeted things to try, I think FP support might be able to look at the logs generated by your phone and hopefully either give you some better options or maybe fix something on their side if required.


Thank you. The phone is not rooted, no modifications. I’ll reach out to the tech support.

You could maybe try out safe mode in the meantime. It could be an app that causes issues. If safe mode is stable, then the crash is probably triggered by an app in combination with the latest FP update. Since most people don’t report this issue, it’s fair to say it might be a custom setup on your phone. You can already rule out the most popular apps, which 99% have installed, such as WhatsApp, Google services, etc. So that limits your search area already a bit. But the first thing is to check if safe mode is working stable. If even that is wonky, then maybe try a factory reset (not ideal, but most of your stuff/settings are in the cloud anyway).

1 Like

Edit: The interrail is not the culprit. The Android update is not the culprit either. The issue was caused by a faulty SIM card. Sorry again for the noise.

Thank you. I am pretty sure at this point that the interrail app is the culprit ( I haven’t seen a single crash after “force stopping” that app. I’ll try to report the issue to the devs of that app. Sorry for the noise here.