Software update Cherry 1.6

Software update v1.6 log - August 2014 states that there are some “security fixes”. Unfortunately I haven’t found anything else on the matter.
Is upgrading really necessary besides the mentioned accommodations?
If so maybe more detailed release notes would be nice.


The unified storage partition was what made me really want to do the update :slight_smile:

Hmm, strange (cc: @visionary): I used the default “Backup & Restore” app as well and it actually restored all my apps, my specific per app settings, my photos, videos, contacts, calendar inputs… Maybe really obvious: but did you check all those boxes when performing the update? :neutral_face:

@aexl - I will ask support to clarify the log, as I think it would be useful to understand exactly what fixes have gone in for example the fake ID bug, would be useful to know if that one is fixed

@aexl, i digged out some posts from @keesj on xda about fixes and possible fixes in the update. It’s not a log and not confirmed but this is what i found:

Yes things are looking good. We will to push an update next week. This will include a few requests from here:

-VOIP calling

-The GPS/SMS = bugfix

-A fix for CVE-2014-0224 OpenSSL

-Lower logcat output and possibly the bluetooth

-GPS fixes (using a different ntp server) and I still hope a fixed EPO downloader.

The only security bug mentioned there is CVE-2014-0224 OpenSSL.
I also remember, but can’t find the source currently, that the “=”-SMS-Reboot has been fixed. This might be security related as well.

1 Like

I am also running into an “Error: Reason of 1004”. Saw your solution below, going to answer to that later. Just to leave this here: I though we left those stupid error messages without any reasonable hint on what is going on in the last century. Seems I was very wrong.

I still have not figured out how to fix it. And I still have no real idea where the problem with installing gapps comes from.

My guess was be that my internal partition only has about 100 mb left, and the apk would be larger than this.

I tried the following (to no avail):

  1. Using Titanium Backup, I backed up all apps + system data to the SD.

  2. Also using TB, I moved all user apps to the SD (which is creating
    symbolic links

  3. I soft-rebooted, as XPrivacy said I should
    (probably due to the movement of apps).

I now have plenty of space on all partitions. However, gapps still refuses to DL and install.

My next step would be to try to unify the partitions using the FP updater. However, if anyone could provide a different angle to tackle this useless error message, I would be delighted.

you need to reflash the 1.6 update (you can use the software app) to get rid of the 1004 error. That’s how I got rid of my problem of not being able to download gapps with this exact error message… Stupid, but it works.

1 Like


The fake ID bug is not fixed. We should get a fix for the next Software update.

I also upgraded from 1.3 with the Fairphone Uploader and now I’d like to upgrade to the unified storage partition as described here, because for some reasons I can’t update my apps anymore (“There is insufficient space on the device”), even there are 269MB of internal storage and around 12GB of phone storage free. I can’t even update an app with less than 10MB, so where the phone needs some space?

So when trying the storage updater, I’m stuck at step 3. I can neither press “Fairphone OS” nor “Stock Android”, there just doesn’t happen anything. Only “More info” can be pressed, which shows me the Android version of 4.2.2. Does anybody else have this problem?

@Robert_P Keep tapping on the install-button. i quit the app, opened it again, rebooted the phone, put it on held, set the phone to sleep to wake it up again to get it to understand and finally it did.

I moved 6 posts to a new topic: No Google Apps Widget after v1.6 update

Hey there. I am just now dicovering problems with my update, as app-updates are lining up, because of insufficient space. I tried to work my way through the forum and discovered the unified partition thing, but there I got into trouble, for it is not working as decribed. I get as far as step 2, and step 3 is not working on my device. I can push the FairphoneOS-button as much as I like, there is simply no reaction.
Any suggestions?
Thanks so much!

Hi, yes I’ve used the normal “Backup & Restore” app. But I have just secured my apps. Contacts and calendar syncing with iCloud. (CalDAV)

The app were all there - only they have not everything works …

Well 1.6 so far: I haven’t noticed anything different except battery life is now a complete mess. :frowning:

Previously I could get close to 3 days, with the weird 1 day of 14%, but now it drops to 1% within about 30 hours. Interestingly it’s been on 1% now for about 11 hours, so it seems like the 14% issue is now a 1%. Unfortunately that’s even more annoying as I won’t have a 13% buffer when I finally see the plateau finish, it will just die. I’ll have to start charging it in about 4 or 5 hours if it doesn’t run out.

I pressed “install new version”, nothing happened as others have mentioned, also reboot didn’t help. Then I pressed the button like ten times in a row, now the download starts!

Hi, I finally downloaded the update and it starts normally until it reaches the end of the download, then a short message appears “file downloaded invalid”. After that I’m back at the fair phone updater home screen. I did not read anyone else mentioning this issue. Do you have a solution? I use a Fairphone 2nd generation with the 1.5 currently working. I have tried at least 5 times to install it. I tried to turn it off then on before the download.
Thank you for your help.


After searching for a month or so, tried some repair Apps, visited numerous forums, but I still haven’t found a working solution. Now more and more Apps require updating, which needs GPlayStore, which doesn’t work. So I’m getting more and more unhappy. Google support points to the manufacturer of the device, so I’m turning back to Fairphone support: any suggestions left?

I might have missed something in this rather long thread, but have you ever completely reset your system? (‘hard reset’, see )
Yes, it’s a nuisance (to put it mildly) since you’ll have to spend some time to set everything up afterwards, but it might be what’s needed.

After Update to Cherry
Google Play Store App:
At first there was a malfunction stating connection problems.
By now the Icon on desktop screen, when pushed, states: App isn’t installed.
I tried to reinstall Play Store over browser. I didn’t manage. What Tod do??? Please advise.