Software Update: Android 11 for Fairphone 3 and 3+

Hello dear compatriot @clemsys,

I’m in the same situation than you: no upgrade available at this time.
I’m using two SIM cards: the main one under SFR network and the second one under Free Mobile network.

Wait & see!
I just hope not to get an upgrade reminder notification during my whole holidays :wink:

Has anyone have any information about this issue with not being able to choose SD as the storage location for the camera app? Will this be fixed, because in my opinion this is obviously a (annoying) bug. If this was a feature, I don’t think you could even choose SD in camera app. I don’t want to install any new apps to do this.

Also, has anyone else had any issues with opening the camera app from double clicking the power button or swiping the lock screen? I have. Especially when using the camera frequently, it tends to not open. If I use the two forementioned methods, it first looks like the phone is about to open the camera, but then just a black screen with the lock icon appears. Maybe this has something to do with the fact that the internal memory is getting full, but it’s very inconvenient to start using the files app every once in a while to move files, when there’s something you want to video or photograph.

Yes this is in the pipeline and due in an update

1 Like

This is discussed in a recent topic here (though the initial question was about removing the icon from the lock screen).
I don’t think this has anything to do with available memory as I sometimes see the problem and I have plenty of memory both internal and SD card. Seems to be a bug so don’t hesitate to make Support aware of the problem to add weight to getting it fixed.

As a work-around when you’re doing a lot of photography, if you have registered a fingerprint correctly you should be able to access the camera pretty quickly, especially if you leave it open when you lock the phone.


Hi everyone, since the upgrade I’m having trouble with my microphone not working in certain apps. Anyone else having the same issue or know how to solve it? I have tested the mic and it works fine, e.g. in video calls (although it has always been difficult for others to hear, but that’s a separate problem). But since the upgrade it does not work at all in one of my recording apps (Audio Recorder), in recorded messages for WhatsApp or in DuoLingo. In the case of Audio Recorder, I get a message that the mic is in use by another app, but I can’t tell which is the problem. In settings, the following apps have permission to use the mic: Audio Recorder, Camera, Chrome, Duolingo, Gboard, Google, Messages, Otter, Outlook, Phone, Skype, Sound Recorder, Teams, WhatsApp, Zoom. Thanks.

Hi and welcome to the forum.

There seems to be an option to stop google from having access to the mic and that has resolved it for some. You can search but here is an example though FP4

It could be an Android 11 issue so affecting the FP4 too

1 Like

Thanks a lot for your response. Unfortunately disabling Google’s permission to use the microphone didn’t solve the problem in my case. I also tried to disable Chrome’s but that didn’t work either :frowning:.

1 Like

Hi! I just updated my phone to Android 11, and I noticed a few changes with it.

First if all, for some reason the font size is messed up and everything is smaller. I guess that’s because it’s optimized for larger screens? But obviously my screen didn’t get any bigger with the update, and now I have to choose between having everything in a smaller font, or having some apps in a bigger font than before. This is really annoying and a weird thing to change.

Also the tiles (or whatever you call these things above the notifications) now only drop down two rows instead of three, which means that I have to swipe more to get to the ones I’m looking for.

The navigation is also different. If you go to the switch apps screen, the buttons for the apps saved in the lowest row are now missing for some reason, I used these a lot. The layout of the three button navigation also changed, the buttons moved a bit away from the center. The symbols also have new models.
The forum doesn’t let me upload images for some reason, so here is a comparison:
The old one:

And the new one:

It has also become slimmer, as you can see by the thicker line above it. That’s all not bad per se, but I noticed that the ring in the circle in the middle is not fully even, and now I can’t unsee it, and it’s just a small thing, but it’s really bothering me.

Is there a way to change any of those things?


Please see post 7 above :slight_smile:


Waited a while to install this update just in case but I have to say everything did work at once - quite a nice surprise :grinning:

So far after two days no problems with wi-fi or anything else.
Did adjust font size and for now am pretty happy.

I’m not totally certain about this yet but it seems that the battery now does last a little longer.


Ever since the update to Android 11 on my FP3, I have these problems:

  1. Some videos (both pre-existing and newly made) appear as black in the Gallery, and file size = zero. :worried: Detail: I don’t use an SD card, but internal memory.
  2. Google Assistant does not respond to speaking “Hey Google” out loud, at all. And yes, the toggle switch in the settings is turned on.

What can be the cause and how to solve?

I’m starting to wonder when the FP3 will get the next software update, the first since Android 11 was rolled out. The FP4 has received two updates since May. It is now at “Security Patch Level: 5th of June, 2022”.

I have no idea how severe the security problems that got fixed on the FP4 really are, but the Android Security Bulletins for May and June list numerous fixes with severity “high”.

Anybody got any information? I don’t want to open a ticket just because I overlooked something. But my phone is definitely still on the initial A11 release and not update is available from Vodafone Germany.

1 Like

Thank you for mentioning that; I already thought I am the only one who is worried about missing security patches :wink:
Especially as Android on the FP3 itself is already warning about this outdated version (red color under “security”).

No, sorry. But also very interested about news.

Hello, I’m trying to update a Fairphone 3 from Android 10 to 11, but when I make it look for updates, it says it’s up-to-date. I know several devices are not eligible at the same time to the update, but after 3 months, I’d like to know if the delay is still normal, or if I have to do something about it.

Ty ! <3

Hi and welcome. Have you tried to restart the phone? You can try to take our SIM card(s) and check if available via Wifi, if not which SIM Provider do you have? Which Android 10 Version exactly do you have installed, you can check under settings, about the phone, build number

1 Like

hi, rebooting and searching without a SIM both didnt work, I’m afraid.
The current Android version on the FP3 is 8901.3.A.0136, so the last update before the Android 11 update.

Hi there,
As yvmuell asked, could you indicate your network operator (carrier) and country? Unavailability of updates is usually linked to the carrier.

In all cases you should #contactsupport about this, Fairphone need to know otherwise they can’t act.

1 Like

The carrier is SFR, located in France.
However, even w/out the SIM card it won’t update, so maybe I could install Android 11 manually with this guide :

You could, however in case your bootloader is not already unlocked, all your data will be erased and you have to setup from scratch. In case you dont want to contract support you can try a SIM from another provider

1 Like

So that’s two or three in this thread with SFR who haven’t received the update.
@tb06 , @clemsys do you have any news?

@Honeyxilia as yvmuell says make sure you have recent viable backup before unlocking the bootloader! If you’re doing standard Gg backups make sure it’s up to date and you should be OK.

Edit - P.S. - don’t forget that relocking the bootloader will also delete your data, so don’t do much except updating the OS, between unlocking and relocking.

1 Like