Software Update: 3.A.0132.20211027

Yes, I did. Several times.

Can you try the other SIM slot? Can you check if you have enhanced LTE mode (VoLTE) enabled or disabled?

Ist es wirklich ‘Private Nummer’ und nicht ‘Unbekannt’? Letzteres war bei mir vor dem Update. ‘Private Nummer’ deutet eher auf absichtlich unterdrückte Nummern hin.

Is it really ‘Private Nummer’ and not ‘Unbekannt’?
Because that’s something different. It was ‘Unbekannt’ before the update, ‘Private Nummer’ appears, when someone doesn’t want his number to be seen.

Ja, seltsam. Tatsächlich kommen ALLE Anrufe so rein, seit dem (damaligen) Update, und von den Geräten, mit denen ich das getestet habe, hat keines eine Rufnummer-Unterdrückung. Fun Fact: wenn ich auf 2G/3G umstelle, wird stattdessen “Unbekannt” angezeigt.

Mysterious … it is allways “Private Number” since the Update in September. None of the devices from which I called my phone uses that function to not show the number …
Only if I switch from 4G to 2G/3G, it’s not “Private …” but “Unknown”.

Yes, there is:

1 Like

I’ve been using a FP3+ for over a year, stock Android kept up-to-date (though as I write, still on 3.A.0129). I just checked, I don’t have this problem and haven’t seen it. I conclude it might be a tricky one to reproduce, diagnose and fix, and is not fully blocking a fuctionality, just a bit of a nuisance.

P.S. - just a thought about the Bt icon thing: … but I’m taking the conversation over to the other thread


Thx, I now have tried the other SIM slot, but the problem is still there. LTE is enabled.

Updated my Fairphone 3 this morning. Brightness bug seems to be fixed.
However, Incoming caller ID still appear as ‘unknown’ when 4G LTE-mode is enabled.
(Netherlands, provider: Tele2)

Did that start with the last update or did you have the unknown bug before? Because the now fixed issue was reported with Vodafone Germany since 3.A.0129.20210805

1 Like

I’m quite sure, that it started with that update (in September, right?). It took a couple of days before I realized, that it is not a problem with my dialer app or vodafone, so I can’t remember the very day, when that problem appeared for the first time.

I was asking Joey_Cramer, because he is not using Vodafone Germany :wink:.


Thank you for your question. It started a couple of weeks ago. I was able to see the callers ID again by disabling LTE. After the update this morning, I enabled it again. Unfortunately caller ID’s are still unknown.

1 Like

Thanks for fix the brightness level bug, works fine here (FP3) :smiley:

1 Like

Did you send a note to Fairphone support about that issue? Maybe they were not aware of this problem with your provider and therefore didn’t contact him to solve the problem.

So just 4G/LTE or in addition enhanced LTE mode=VoLTE? If the latter can you disable? Or do you use WiFi calling? How old is your SIM card?

I have the same problem with Tele2 in the Netherlands. It started on 2 November, so it is not related to update 132.

Only way to fix it for me is to disable both Wifi calling and enhanced 4G LTE calling (HD). Luckily I can still use a 4G data connection without problems.

I have a support ticket at FairPhone about this problem already. Will update it with information regarding the latest update.


Fixed an issue that was causing, under certain conditions, the brightness level to go to zero when set to Automatic.

Thank you so much for that.

A relatively minor bug, but having the display brightness be 0% or roughly 40-100% brightness with nothing inbetween was getting very old very quickly :stuck_out_tongue:

1 Like

It’s just 4G, no VoLTE and I don’t use WiFi Calling. My SIM Card is about 1 year old, it came with my FP.

1 Like

I would contact VF and FP to see what they say


I got the new update today. It installed without issues. After a couple of minutes I can already tell that the most noticeable thing with the update was the fix for the brightness issue. I really appreciate that this got rolled back/fixed. I will let you know if there is anything that might not has been covered.