Soft-bricked FP2 after Lineage OS

Hello Guys,

although I already read a whole lot of articles and comments an such “soft-brick” issues, I do unfortunately still have the following problem:

My FP2 ist constantly rebooting, therefore I cannot access anything besides the Fastboot mode.
I got these problems since I installed TWRP, furthermore Lineage OS and also Magisk, etc.
The OS worked fine after the initial installation but some days later (probably due to some apps) the bootloops occured.

Henceforth I tried:

  • Wiping/Formating Data (I used to get into recovery mode of TWRP, actually I cannot so anymore).
  • Wiping/Formating via Fastboot (cmd shell in W10), which didn’t work out, the phone did not react (I think thats since the bootloader access is denied).
  • Flash the latest TWRP recovery via Fastboot, which works fine - I still can’t access the Recovery-mode.
    -Installing Fairphone Open OS via the script-file (each automatic und manual), the script worked successfully, my phone is still not booting into anything besides Fastboot-mode.
  • Installing Fairphone OS via the script file (the same with Open OS applies here).

Okay - Now I am out of cues. I can’t do anything with it, at least I managed to make the charge-procedure able again, hence I do have 2 batteries - both work.

I really hope that somebody can help me here, thank you very much!

You might at least check/clean battery connection although I don’t think that’s the problem if Fastboot status is stable.
I assume all flashing (TWRP, Fairphone OS etc.) results in an “OK”?
Well, then, sorry, that’s not much of a help, but it might be a problem of the core module (e.g. memory problem). Maybe it was unrelated with your TWRP/LineageOS/Magisk installation and the bootloops started when core module broke…

Okay, thanks for your comment.

It finally worked to install the Fairphone OS. That means my phone was able to be charged right normally with the coherent LED-lights. I could start the phone with the stock OS, it boots until the FP-Logo appears, furthermore the four blue moving dots do appear but then the phone reboots/turns off.

So in conclusion you might be quite right, that the phone hardware is broken now…
The battery connection seems to be quite clean.
The flashing was “OK”, yes.


As I am now able to boot into Recovery-mode, is there any opportunity left? Those wipes dont contribute anymore…

Please have a look at whether there’s something here that you haven’t done already …

In case the fastboot command doesn’t detect your phone in Windows 10 … Fairphone 2 in fastboot mode is not found by Windows 10.


Thank You. I want to follow this guide, however my phone isn’t able to reach the recovery mode. Instead it does freeze at the FP-Logo or it bootloops again.

/edit: It’s worth to mention that this occurs after the I flashed TWRP according to the guide.

As long as Fastboot Mode still works, you can boot a signed TWRP image (that’s not the same one you can flash to the phone) via fastboot, see #twrpwoflashing.

1 Like

Ok. My Output:

Blockquote C:\platform-tools>fastboot boot twrp-3.2.3-0-FP2.img-signed.img
Sending ‘boot.img’ (10361 KB) OKAY [ 0.325s]
Booting OKAY [ 0.011s]
Finished. Total time: 0.378s

What happens now is that the bootloop starts again.

Are your reboots happening on a somewhat constant rhythm or are they happening after completely erratic time spans? I’m asking because reboots are not necessarily always caused by software issues. A blocked power button or a battery not sitting tight at its contacts are hardware problems that have caused FP2 reboots.


At many times, the reboots “froze”, so there was only the constant FP-Logo visible. However after the last booting of the signed image, the reboot was rhytmically.

There’s a good thought … Does it still reboot if you take the case off and try booting TWRP again (might be a bit tricky to push a button, but it’s doable)?

1 Like

This changes nothing. The power button seems to be ok (at least superficially) and bootloop is still going on.

1 Like

With a gentle press of the buttons to get into the recovery mode (I also opend the phone to look if there are any technical problems, which I couldn’t find) I got into the recovery mode of the newly TWRP. I was wiping everything and formatting data, just as the mentioned guide above explains. Everything worked, besides that the phone rebooted automatically after formatting the data.

Result: bootloop (bootfreeze tbh).

Did you eventually solve you problem?

Do you remember what the TWRP log showed? Did it reboot exactly when formatting finished (so it may be due to TWRP?) or did it reboot just after (then it could be a coincidence)?

Hi Alex,

I didn’t solve the problem. Unfortunately, I don’t remember, what the log said. I tried it several times until I considered the phone to be dead. Well, I used to like the Fairphone, unfortunately they tend to get even bigger, so no new devices for me :smiley:

@monologue had the kindness of sending me the phone so that I could have a look at it.
I could access Fastboot mode okay, but then trying to flash TWRP would either 1. fail and the phone reboots 2. showed it succeeded but it failed 3. succeed, but it only happened once, and then I tried to format data in TWRP and as soon as I tapped on the button it rebooted. I tried multiple TWRP images, booting into a signed image (#twrpwoflashing), nothing succeeded. When rebooting, the phone would not reach fastboot mode like bootlooping devices I hav seen often do, but just stay hanging on the splash screen.
Trying to reinstall FPOS from fastboot with the script failed, manually flashing each partition resulted in the phone randomly rebooting when flashing some partitions, while it showed other succeeded. And then when coming back to fastboot and flashing the same partition it would output a success, until it rebooted when flashing a next one. So I tried flashing all partitions until it showed at least once a success for each of them, but no surprise, at the end there was nothing.
I tried reaching EDL mode to process with some unbricking, but pressing the button combination for EDL (Power + both volume buttons) made the phone reboot every 2 seconds as long as I held the buttons, and it would as usual always finish on the splash screen. Edit: Trying to boot into EDL from fastboot (fastboot oem edl) results in the same.
At some point by pressing some button combination I even reached a strange black screen with the Fairphone logo alone in small text (it happened three times), I managed to get a picture before it rebooted:

If you know what this mode is, I’m interested (I checked and it’s not EDL mode).

So same symptoms as @monologue. No surprise nothing worked, it seems to me the bootloader is corrupted. What excludes reboots due to hardware is that the phone would reboot as soon as some command was entered (or in TWRP the button tapped), but moving it, twisting it, hitting it a bit wouldn’t make it reboot, and it could stay hours on in fastboot mode without rebooting if just left lying on a table. Power button seems also ok.
I will try working on an unbricking procedure. If it works I will document it on the forum, if it doesn’t I will scavenge the phone for spare parts.

Edit: Slightly modified a sentence
Edit2: Typo


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.