SMS memory full - not able to receive

Dear all,

Since a week or so my Fairphone 1 gives off the notification that my SMS memory is full and that therefore I cannot receive any text messages. I have cleared all messages and the memory from the app, but still get the warning and am still not able to receive text messages.

Is anybody familiar with this problem / does anyone have a solution?

Thanks in advance!

Did you check if SMSes are saved on the phone instead of the SIM card?
You can check this in the settings of the messaging app and verify the position of SMS saving (you can choose for each SIM card if you use both SIMs).
Bye! :smile:


Thanks for your reply DjDas! The SMSes are already being saved on the SIM, and I have deleted everything so there are none left.

Any other suggestions of what this could be?


1 Like

Shouldn’t the be saved onto the internal storage? I think my SIM card only has a capacity of 20 SMS. No wonder your SMS storage is full! :slight_smile:

PS: to see the messages stored on your SIM, go to the SMS app > “Menu button” > settings > text messages (SMS) > messages on SIM card .

1 Like

Thanks for the reply Stefan, however I have deleted all the messages from the SIM and cleared the app’s memory, and I am stil not able to receive messages and continue to get notifications saying that the memory is full…

1 Like

Your SIM card might be defunct. The first thing to try is to switch it to the second SIM slot and then to get a new SIM card.

1 Like

Did you also store (and delete) the sent messages on the SIM card? I once had the same problem on an old phone, apparently the sent messages where taking all the space I needed to store received messages…

1 Like

Thank you for the suggestion @danielsjohan, I have also deleted those!

@Stefan I’m using the second SIM slot and it seems to be working: so far I am not receiving the notifications anymore…will test to see if I can receive messages.

Thanks for all the help!


You should select the phone memory as default device to store messages on, especially because SIM cards don’t offer that much space for storage. You can change this setting in the SMS-App.