Since update all incoming calls are 'unknown'

Since the latest android update all of my incoming calls from contacts are ‘unknown’. Any ideas?

Welcome to the Community Forum.

This has occured in the past a few times, I think it’s usually an issue of adapting Fairphone OS to specific provider/carrier/network needs. I strongly recommend you contact Fairphone Support at https://support.fairphone.com/hc/en-us/requests/new and let them know about it (their form there will probably ask you to specify your provider anyway). In this forum we are (almost) all users “only”. :innocent:

1 Like

Come on Samsung, get on top of this issue.

Come on Huawei, get on top of this issue.

Come on Xiaomi, get on top of this issue.

Come on Sony, get on top of this issue.

And yes (please try to ignore many hits which are pretty old and concentrate on the newer ones) … Come on Apple, get on top of this issue.

(Feel free to add more vendors.)

3 Likes

Support may well send you this link and say that unless you’re on one of the few supported providers, you’ll have to disable voice over LTE and voice over WiFi to make caller ID work again:
VoLTE and VoWiFi compatibility

There is only one supported network in the UK (for FP3) and a I’m not on it!

2 Likes

Disabling LTE and voice over WiFi doesn’t work. In settings I used ‘Clear Mobile, data and bluetooth history’ and it fixed

1 Like

Interesting. I searched for “Clear” and"History" in settings and didn’t find that option

Hi
settings-system-reset options-reset wifi,mobile & bluetooth
beware you will need to reconnect all your wifi passwords and bluetooth devices. It worked for me, will be interested to know if it helps

Since October 31st all incoming calls from contacts are listed as “unknown” (“ukjent”) - I think it happened after the latest android update.

You may want to have a look at this thread:

PS- And welcome to the community forum!

2 Likes

I merged the 2 topics.

2 Likes

Thank you! I tried doing what Ricky_Linn suggests - resetting wifi, mobile and bluetooth - it worked! Thanks again for pointing me in the right diretion.

2 Likes

That’s great that worked for you :grin: Although I think Fairphone should send me a shiny brand new phone for fixing this for them…:thinking:

Ups, I rejoiced too early: When I reset wifi, mobile and bluetooth, incoming calls are recognised, but: Mobile data are not activated, and when I reactivate (I have to go into the settings, and type in all the APN settings, authentication, protocol etc), incoming calls are again not recognised, This is super frustrating! Either I have no mobile data (and my phone is no longer a smart phone), or I do not know who has tried to call me… Anyone out there that can help?

You need to explicitly save these settings. The save button is in the menu (top right of the screen) at this point.

Might be an incompatibility with VoLTE …

1 Like

Thanks all - I think maybe it is solved after I turned off voLTE, fingers crossed!