Since Nougat update I can't catch Pokemon anymore

I understand nothing. That’s too high for me.

1 Like

Seems that this is the error that causes the crash of Pokémon go (Process com.nianticlabs.pokemongo (pid 29560) has died).

I tried searching google for “Pokémon Go” + “E libEGL” or “pokémon go” + “call to OpenGL” but I didn’t find anything relevant… This error may be FP2-OS related, then!

I’m afraid I’m not able to go deeper in the debugging… :frowning:

Just to check: are you using FPOS or FPOpenOS ?

1 Like

This may be a stupid question (as the app may refuse to run), but what happens when you deny camera access permission?

@oli.sax thanks for your help anyways. I’m using FPOS.

@Johannes when I deny the camera access permission it crashes the same way as it would with the permission granted. I didn’t compare the logs yet. Do you want to see the log of that specific kind of crash?

I recall reading that on some devices AR is disabled when the app cannot detect a camera. Whether revoking permission has the same effect, I’m not sure, but it was worth a shot.
I’d imagine the crash is still the same, and unfortunately I have no idea what you can do to avoid it.

I’ve already tried that, crashes anyway,

Thank you all for the suggestions and the work on a solution!

I think I will try installing lineage15. oli.sax was it very difficult to run pogo on it? I googled a little bit and there was a tutorial recommending the iSU app. Which SU tool did you use? Added you as friend, too :wink:

Friend request accepted :slight_smile:
No, the installation of lineage15 is quite simple. Just remember to backup your current OS (via TWRP e.g.) and all your data (internal data like pictures are not included in TWRP backups.

For the root hider I use iSu, it is simple as well :smiley: . I added the iSu widget on my home screen with root on/off.


As documented on the bug tracker, Fairphone currently only supports OpenGL ES 2.0 in Android 7 while OpenGL ES 3.0 was available in Android 6. This might be a good candidate for the root cause of this bug.


Finally we have some idea what this might be about. Any idea how long it might take to solve this? The bug tracker entry is from October 11th, so that’s one month already. I don’t fancy waiting for this long…

1 Like

Thank you oli.sax, that sounds very encouraging. If I feel brave enough, I’ll give it a shot tonight and share my experience :smile:
and thx to ChuckMorris, that we now seem to know what’s the problem…


Then you can delete the game without opengl ES 3.0, so do not comb it !!!

I installed lineage 15 today almost hassle free following the lineage wiki guide
and as I didn’t root it, no problem playing Pogo.
Phew it feels good :sweat_smile:


Nice! I guess I’ll try it too. That “minor problem” got pretty annoying.

Thanks everyone for your help!

Sorry, but I think it’s kind of funny, that the upgrade to Android 7 makes Pogo-Users switching to Lineage OS.
Somehow I guess, that was not intended. :grin:


Well, offering Android 7 with OpenGL ES 2.0 while 3.0 has been available since Android 4.4 is kind of funny too :thinking::grinning:


I have the same problem like the person in the beginning, so after updating for Android 7.1.2 Pokémon Go is crashing all the time while I am tipping with my finger on a Pokémon. Everything else is runing. Iam a zero in doing computer stuff. So should I wait till there is a new Fairphone update? Or how can I turn the update for 7.1.2 back to Android 6? Thanks and best wishes

1 Like

I didn’t manage to install Lineage in the end. So I’m waiting for the next Fairphone update too – hoping it will fix the problem.

Since the issue has been identified on the bugtracker, it would be good to upvote the issue there. So it gets the attention it deserves and we hopefully get a quick fix without having to change to a different OS :wink:


I don’t think i know how to upvote. Tips?