Since Nougat update I can't catch Pokemon anymore

I’m from Austria. What do you want to talk about? :slightly_smiling_face:


ich wollte mich nur nochmal austauschen und fragen ob es nicht noch eine andere Möglichkeit gibt.

Hab schon überlegt Android 7 runter zustufen. Weiß aber nicht ob das sinnvoll ist oder geht?
VG Tim


I would like to talk about the buck and hope, that there is another possibility. It is posible to downgrade Android 7?

Best wishes Tim

Yes ! Look at the FAQ, part “how to downgrade” :slight_smile:

1 Like

I’ve considered downgrading too, but I’m not brave enough to do that. :see_no_evil: Plus, I found a workaround to play PoGo: I’m borrowing my gf’s phone. :joy:

If you really want to downgrade, you need to take the following steps (I think):

  1. back up your data (guide)

2̶)̶ ̶m̶a̶n̶u̶a̶l̶l̶y̶ ̶i̶n̶s̶t̶a̶l̶l̶ ̶A̶n̶d̶r̶o̶i̶d̶ ̶6̶ ̶-̶>̶ ̶h̶e̶r̶e̶ ̶i̶s̶ ̶t̶h̶e̶ ̶[̶g̶u̶i̶d̶e̶]̶(̶h̶t̶t̶p̶s̶:̶/̶/̶s̶u̶p̶p̶o̶r̶t̶.̶f̶a̶i̶r̶p̶h̶o̶n̶e̶.̶c̶o̶m̶/̶h̶c̶/̶e̶n̶-̶u̶s̶/̶a̶r̶t̶i̶c̶l̶e̶s̶/̶2̶0̶7̶9̶1̶4̶3̶6̶3̶-̶M̶a̶n̶u̶a̶l̶l̶y̶-̶i̶n̶s̶t̶a̶l̶l̶-̶F̶a̶i̶r̶p̶h̶o̶n̶e̶-̶O̶S̶-̶f̶o̶r̶-̶t̶h̶e̶-̶F̶a̶i̶r̶p̶h̶o̶n̶e̶-̶2̶)̶ ̶f̶o̶r̶ ̶m̶a̶n̶u̶a̶l̶l̶y̶ ̶i̶n̶s̶t̶a̶l̶l̶i̶n̶g̶ ̶A̶n̶d̶r̶o̶i̶d̶ ̶7̶.̶ ̶I̶ ̶t̶h̶i̶n̶k̶ ̶i̶n̶ ̶o̶r̶d̶e̶r̶ ̶t̶o̶ ̶g̶e̶t̶ ̶A̶n̶d̶r̶o̶i̶d̶ ̶6̶,̶ ̶y̶o̶u̶ ̶m̶u̶s̶t̶ ̶n̶o̶t̶ ̶i̶n̶s̶t̶a̶l̶l̶ ̶t̶h̶e̶ ̶z̶i̶p̶-̶f̶i̶l̶e̶ ̶s̶h̶o̶w̶n̶ ̶i̶n̶ ̶s̶t̶e̶p̶ ̶o̶n̶e̶ ̶i̶n̶ ̶t̶h̶i̶s̶ ̶g̶u̶i̶d̶e̶,̶ ̶b̶u̶t̶ ̶i̶n̶s̶t̶e̶a̶d̶ ̶u̶s̶e̶ ̶t̶h̶e̶ ̶f̶i̶r̶s̶t̶ ̶z̶i̶p̶-̶f̶i̶l̶e̶ ̶[̶h̶e̶r̶e̶]̶(̶h̶t̶t̶p̶s̶:̶/̶/̶s̶u̶p̶p̶o̶r̶t̶.̶f̶a̶i̶r̶p̶h̶o̶n̶e̶.̶c̶o̶m̶/̶h̶c̶/̶e̶n̶-̶u̶s̶/̶a̶r̶t̶i̶c̶l̶e̶s̶/̶2̶1̶3̶2̶9̶0̶0̶2̶3̶-̶F̶a̶i̶r̶p̶h̶o̶n̶e̶-̶O̶S̶-̶d̶o̶w̶n̶l̶o̶a̶d̶s̶-̶f̶o̶r̶-̶F̶a̶i̶r̶p̶h̶o̶n̶e̶-̶2̶)̶ ̶n̶a̶m̶e̶d̶ ̶"̶F̶P̶2̶ ̶-̶ ̶U̶p̶d̶a̶t̶e̶ ̶f̶i̶l̶e̶ ̶o̶f̶ ̶F̶a̶i̶r̶p̶h̶o̶n̶e̶ ̶O̶S̶ ̶1̶8̶.̶0̶4̶.̶1̶ ̶f̶r̶o̶m̶ ̶1̶8̶.̶0̶3̶.̶1̶"̶.̶ ̶T̶h̶a̶t̶’̶s̶ ̶b̶e̶c̶a̶u̶s̶e̶ ̶a̶c̶c̶o̶r̶d̶i̶n̶g̶ ̶t̶o̶ ̶[̶W̶i̶k̶i̶p̶e̶d̶i̶a̶]̶(̶h̶t̶t̶p̶s̶:̶/̶/̶d̶e̶.̶w̶i̶k̶i̶p̶e̶d̶i̶a̶.̶o̶r̶g̶/̶w̶i̶k̶i̶/̶F̶a̶i̶r̶p̶h̶o̶n̶e̶_̶2̶)̶ ̶"̶F̶a̶i̶r̶p̶h̶o̶n̶e̶ ̶O̶S̶ ̶1̶8̶.̶0̶4̶.̶1̶"̶ ̶i̶s̶ ̶t̶h̶e̶ ̶l̶a̶t̶e̶s̶t̶ ̶v̶e̶r̶s̶i̶o̶n̶ ̶o̶f̶ ̶A̶n̶d̶r̶o̶i̶d̶ ̶6̶.̶
LISTEN TO AnotherElk

Downgrade at your own risk though. :ghost:

Good luck! :four_leaf_clover:

ps: If you want to play it safe, you can contact support, I’m sure they can guide you through the process. :innocent:

1 Like

So I downgraded mine to Android 6 last night. And had no problem with it, although I did not have such a genius regarding such things.


Sorry, but this is wrong.
As long as 18.04.1 is still offered on the page along with this guide …

… this guide is totally correct and to be followed in detail.

A guide with a direct download link to 18.04.1 (in case the download on the support page switches to 18.09.2) is here (“I regret upgrading, how do I downgrade?”) …

You are instead advising to use an incremental 18.03.1 -> 18.04.1 OTA update file intended for use with the Updater or the recovery … with the manual fastboot installation procedure for installing the whole OS … Good luck with that, indeed. It will not work.


Sorry, I didn’t mean to spread misinformation. :dizzy_face: I’ll edit my post accordingly.
Thank you for clearing things up! :+1:


Don’t worry … you had backing up data as point 1, that is very commendable, more people need to do backups.
When people have restorable backups, any failed installation experiment can still be sorted out somehow, at least on the Fairphone 2.


Hi W4tler,
did you download all those 20+ files or are these just versions of the same? I thought I would skip all that and do a factory reset right away. It keeps resetting to Android 7. Frustrating! I would like to use my phone tonight and I can’t find my old phone anywhere.
cheers, Anouk

1 Like

Hi Another Elk and everyone.

After I didn’t manage to install Lineage some time ago, I now tried to downgrade to Android 6. The tutorial seemed to work pretty smoothly, but afterwards I got really weird error notifications (“android.process.acore” and"), they didn’t stop appearing. And after restarting it it got stuck doing app optimization. I was kind of afraid I ruined my phone now.

Luckily the reinstallment of Android 7 worked fine and everything is back to “normal”. I hope with the next Fairphone update OpenGL 3.0 will be supported again.

Thanks for sharing the instructions still, nevertheless.

1 Like

Hi there, thanks for sharing your issue, I am having the same problem and I was getting a bit desperate :frowning: . I have been reading through the posts but I am not sure if you managed to solve the Pokemon Go issue in the end by downgrading to Android 6 and then back to 7 or not?
Thanks !

Currently, the only “workaround” is to either downgrade to Android 6 (and stick with that until Fairphone will offer an update that fixes the issue) or switch to a different OS (e.g. Lineage).

Ok thank you very much, I will give one of these options a try (or maybe just wait an be patient :roll_eyes:).

Hi Leo,
hi Community,

I face the same problem - even trading isn’t possible any more.
The app has become redundant, the object of the game is lost.

I asume, it has something to do with necessary workarounds (like USB-debugging) activated in developer mode (although I deactivated the mode later).


Currently this here is much more likely …

And your current options are …

For details please read the posts in this topic.


hi, Anouk!
nope, I haven’t done anything yet. my “workaround” is to borrow my girlfriend’s phone every evening when I go for a walk. :sweat_smile: I still hope that the problem will be solved soon so I can use my FP2 again.

Hi Everyone,

Thanks a lot for all the data you gathered and trying to find solutions! Maybe this is the bootstrap I needed to install an alternative OS on my fairphone :smiley:

I’m waiting for an update to fix this.
At least can I spin stops and walk my eggs (it’s a kind of soft detox :laughing: )

1 Like

I should have checked the forum earlier, would have saved a lot of time resetting and clearing caches :wink: Thanks for spending the time figuring the potential issue out! I agree that sounds reasonable.

Until this is fixed I dug out my old phone and created a hotspot on my FP2 to have internet access. Finally I am one of these guys with 2 phones.

1 Like

I just found out that the same bug appears when trying to trade Pokémon. Does anyone know if the reason for this issue is the same?