Since Nougat update I can't catch Pokemon anymore

I am having the exact same issue here since updating to Nougat. I also tried enabling/disabling permissions and reinstalling the software, but the problem persists.

I have the same problem. And already done everything, cache deleted, uninstalled and reinstalled, but has brought nothing.

I have a simple idea to test if this problem is camera-related or not: could you try adding a new friend with the QR-code camera reading? Me for example :wink:

Otherwise, what we can do is look in the log (activate adb in the developper settings, connect to computer and type ‘adb logcat’ in a terminal) to search a specific message explaining the crash…


I just used my camera to scan your QR code. This worked (and you should now have a new friend request on Pokemon GO).
Trying to catch a pokemon still causes the app to crash.

I’m very willing to work with you to research the matter. I’m not very familiar with developer settings though, could you guide me through?

1 Like

Good Idea oli.sax, I added you as a friend too now.
So I guess it is not camera related.

How do I activate ADB in the developper settings?
I can’t find it (probably because my phones language is German).

There is a wiki here : ✏ How to gather logs

In a summary:

  • [on FP2] you need to go to settings -> developer settings and enable USB debugging. (If you can’t see the menu for developer settings, you need to go to settings -> about phone and tap a few times on the build number.)

  • [on your computer] Install the drivers and Android Debug Bridge. For windows follow this tutorial, for linux sudo apt install android-tools-adb

  • [once your FP2 is connected to your computer] Check that the computer detect the device: adb devices; then open the log: adb logcat

1 Like

That is some hefty installation…
Not sure I’m up to scratch. Are you working on it, LeoLe?

1 Like

I am a beginner too :sweat_smile:

I activated the USB debugging.
Installed Android File Transfer (because my mac didn’t connect to my phone)
and Homebrew because I’ve found this tutorial: installing-adb-on-macos

But now I don’t know how to go on. if I type in " adb devices" into the terminal I get the message “command not found”


Well, I might wait to get back to Germany and have someone read out the phone there rather than ruining my computer…
Anyway, I also opened a ticket with the support, the replied but no solution yet: “Your request 267903 about “Pokemon GO not working properly on Fairphone 2 after Android update” has been updated.” The link in the mail returns a “page does not exist”, though…


Strange, if adb is installed it should find the adb command… Have you tried rebooting?

1 Like

My fault, I skipped one step in the tutorial.
Now adb is sucessfully installed. And I tried “adb devices”.

I get this response and I don’t know what to do next:

List of devices attached
8cccf626 device

do I have to start " logcat" now? can I post a part of the logs (that I think that is relevant) here?

1 Like

That’s the perfect behaviour, it is installed perfectly :slight_smile:
Now just type “adb logcat”, it’ll display all the log in the terminal, or “adb logcat > logFP2.txt” to export it in a text file.
Copy and paste just the lines corresponding to the time pokemon go has crashed…

1 Like

I identified the crash, but I don’t know how much of the log is relevant:

11-19 13:03:53.389 1815 3473 W GnssLocationProvider: Invalid size of GpsSvStatus found: 0.
11-19 13:03:53.650 29560 29576 E libEGL : call to OpenGL ES API with no current context (logged once per thread)
11-19 13:03:53.654 29560 29576 E CRASH : signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 00000000
11-19 13:03:53.654 29560 29576 E CRASH : *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
11-19 13:03:53.655 29560 29576 E CRASH : Build fingerprint: ‘Fairphone/FP2/FP2:7.1.2/18.09.2/gms-4a5ca353:user/release-keys’
11-19 13:03:53.655 29560 29576 E CRASH : Revision: ‘0’
11-19 13:03:53.772 1815 4514 D GnssStatusListenerHelper: Remote Listener died: android.location.IGnssStatusListener$Stub$Proxy@c21cf2d
11-19 13:03:53.772 1815 9749 I WindowManager: WIN DEATH: Window{1531c62 u0 SurfaceView - com.nianticlabs.pokemongo/com.nianticproject.holoholo.libholoholo.unity.UnityMainActivity}
11-19 13:03:53.776 1815 4524 I ActivityManager: Process com.nianticlabs.pokemongo (pid 29560) has died
11-19 13:03:53.776 1815 3073 W InputDispatcher: channel ‘8f2c27e com.nianticlabs.pokemongo/com.nianticproject.holoholo.libholoholo.unity.UnityMainActivity (server)’ ~ Consumer closed input channel or an error occurred. events=0x9
11-19 13:03:53.776 1815 4524 D ActivityManager: cleanUpApplicationRecord – 29560
11-19 13:03:53.776 1815 3073 E InputDispatcher: channel ‘8f2c27e com.nianticlabs.pokemongo/com.nianticproject.holoholo.libholoholo.unity.UnityMainActivity (server)’ ~ Channel is unrecoverably broken and will be disposed!
11-19 13:03:53.776 1815 3293 I GnssLocationProvider: WakeLock acquired by sendMessage(3, 0,$GpsRequest@8d521f3)
11-19 13:03:53.780 1815 1831 I GnssLocationProvider: WakeLock released by handleMessage(3, 0,$GpsRequest@8d521f3)
11-19 13:03:53.780 29187 29187 D BackgroundService: stopping notification
11-19 13:03:53.783 1815 4524 W ActivityManager: Scheduling restart of crashed service com.nianticlabs.pokemongo/ in 1000ms
11-19 13:03:53.784 1815 4524 W ActivityManager: Force removing ActivityRecord{dbc3782 u0 com.nianticlabs.pokemongo/com.nianticproject.holoholo.libholoholo.unity.UnityMainActivity t285}: app died, no saved state
11-19 13:03:53.804 273 273 W SurfaceFlinger: couldn’t log to binary event log: overflow.
11-19 13:03:53.805 1815 22863 I WindowManager: WIN DEATH: Window{8f2c27e u0 com.nianticlabs.pokemongo/com.nianticproject.holoholo.libholoholo.unity.UnityMainActivity}
11-19 13:03:53.806 1815 22863 W InputDispatcher: Attempted to unregister already unregistered input channel ‘8f2c27e com.nianticlabs.pokemongo/com.nianticproject.holoholo.libholoholo.unity.UnityMainActivity (server)’
11-19 13:03:53.815 273 273 W SurfaceFlinger: couldn’t log to binary event log: overflow.
11-19 13:03:53.816 1815 4524 D ActivityTrigger: activityResumeTrigger: The activity in ApplicationInfo{ed5f821 com.fairphone.fplauncher3} is now in focus and seems to be in full-screen mode
11-19 13:03:53.816 1815 4524 E ActivityTrigger: activityResumeTrigger: not whiteListedcom.fairphone.fplauncher3/com.fairphone.fplauncher3.FairphoneLauncher/10005
11-19 13:03:53.820 284 284 I Zygote : Process 29560 exited due to signal (11)
11-19 13:03:53.828 29187 29187 D BackgroundService: BackgroundService onDestroy PROCESS_LOCAL_VALUE = 9899031
11-19 13:03:53.828 1815 22865 I GnssLocationProvider: WakeLock acquired by sendMessage(3, 0,$GpsRequest@809aeb0)
11-19 13:03:53.889 1815 1831 I GnssLocationProvider: WakeLock released by handleMessage(3, 0,$GpsRequest@809aeb0)

shortly after that crash I tried it again - so it would be easier to identify in the logs

11-19 13:03:13.169 28749 28765 E libEGL : call to OpenGL ES API with no current context (logged once per thread)
11-19 13:03:13.188 28749 28765 E CRASH : signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 00000000
11-19 13:03:13.188 28749 28765 E CRASH : *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
11-19 13:03:13.188 28749 28765 E CRASH : Build fingerprint: ‘Fairphone/FP2/FP2:7.1.2/18.09.2/gms-4a5ca353:user/release-keys’
11-19 13:03:13.188 28749 28765 E CRASH : Revision: ‘0’


I understand nothing. That’s too high for me.

1 Like

Seems that this is the error that causes the crash of Pokémon go (Process com.nianticlabs.pokemongo (pid 29560) has died).

I tried searching google for “Pokémon Go” + “E libEGL” or “pokémon go” + “call to OpenGL” but I didn’t find anything relevant… This error may be FP2-OS related, then!

I’m afraid I’m not able to go deeper in the debugging… :frowning:

Just to check: are you using FPOS or FPOpenOS ?

1 Like

This may be a stupid question (as the app may refuse to run), but what happens when you deny camera access permission?

@oli.sax thanks for your help anyways. I’m using FPOS.

@Johannes when I deny the camera access permission it crashes the same way as it would with the permission granted. I didn’t compare the logs yet. Do you want to see the log of that specific kind of crash?

I recall reading that on some devices AR is disabled when the app cannot detect a camera. Whether revoking permission has the same effect, I’m not sure, but it was worth a shot.
I’d imagine the crash is still the same, and unfortunately I have no idea what you can do to avoid it.

I’ve already tried that, crashes anyway,

Thank you all for the suggestions and the work on a solution!

I think I will try installing lineage15. oli.sax was it very difficult to run pogo on it? I googled a little bit and there was a tutorial recommending the iSU app. Which SU tool did you use? Added you as friend, too :wink: