English

SIM not recognised after flashing FP3_A0105 image

Tags: #<Tag:0x00007f05e697b3a8>

Hey there,

I was trying to install a GSI image, which failed. So I flashed the stock image using the upper dump from following instruction: TWRP installable stock firmware packages for Fairphone 3

It worked after chaning the filesystem from the system partition and then it booted successfully.
However my sim cards are not recognised anymore. I tried flashing the modem.img from the A_0110 dump, but did’nt solve the problem.

Any ideas what I can do? I’m not a complete expert in this topic.

Thanks already!

What do you mean by changing the filesystem of the system partition?

You say you are no expert, but you flash the modem.img from one firmware ontop of another?

Install the latest available firmware in full and do a factory reset, that should get everything working.

1 Like

“Not a complete expert” :wink: .

Not that it helps when I say that, but anyway … this could be another example of Fairphone 2 behaviour carried over to the Fairphone 3.
On the Fairphone 2 any version of the modem files (I don’t link to them here now on purpose) could be installed independently of any OS running on the phone. Sometimes flashing a previous version fixed stuff, sometimes flashing a new version fixed stuff, sometimes a particular version was required for Sailfish OS to behave well … those were the days :slight_smile: .

1 Like

That may make sense for custom roms even on the FP3.
The same goes i.e for the vendor-partition in case of GSI.

But with stock OS that seems like a strange thing to do.

Well, yes :smile:

The latest firmware I know is A_0110, right? In the link from the main post the system, vendor and product images are missing, but there seem to be parts (.new.dat.br; .patch.dat; .transfer.list) I don’t know how to use.

A_0105 worked in general, but maybe I’m missing something

After flashing the GSI the installer for Magisk could not mount the system partitition, so I followed the following video: https://www.youtube.com/watch?v=VJRKuQf0puE bad idea?

The ZIPs you linked to are meant to be installed using TWRP (hence the thread title “TWRP installable stock firmware packages for Fairphone 3”
The partitions you mentioned aren’t missing, they are just provided in a compressed format.

I’m not sure, how you flashed the GSI, but I’d refer to you to

1 Like

I tried to use it but it quits with an error:
Patching system image unconditionally…
E1001: Failed to update system image.
Updater process ended with ERROR: 7

What TWRP-version are you using?
Try wiping system first.

twrp-3.3.1-0_k4y0z-20200202-02-fp3
most recent

I’m trying that