"SIM card not valid" - intermittent problem

I intermittently experience the problem that all of a sudden during normal usage the connection to my SIM card breaks. No mobile connection. It then says “invalid card”, a reboot usually solves until it happens again after a few days. The pattern seems pretty random to me.

Provideer ist fraenk (Congstar) in Germany

Anyone else experience this problem?

I assume it’s a physical SIM, right?!
How old is it, how long has it been in use before? :thinking:

Physical. In use for a couple of months. I guess I will get my provider to send me a new one.

Hmm, shouldn’t fail after such a short amount of time, but can happen, yeah.

According to their website they support eSIM, that would at least be a quicker way to test a new SIM :slightly_smiling_face:

Hey there,

I have the same issue, and this is intermittent as well.

This is quite difficult to reproduce, as it may work for a few days, then happen twice or thrice a day, then disappear again.

I cannot remember how old my SIM card is ; I bought my FP4 9 months ago, but I cannot remember whether I used a new SIM card or not when I switched phones.

@Casukarut did your issue go away with a new physical SIM? Thank you!

Yes, a new sim card solved it! Even though my old one was quite new as well.

2 Likes

Sometimes SIM cards can get a bit dirty and may benefit from cleaning.

Also if it’s a tight fit width ways it can bend and the contacts may not meet properly.

2 Likes

Thank you both for your replies. I ordered a new SIM card, so we’ll see. For now, I added a slim piece of paper on top of the SIM card, as my phone would not recognise it after 3-4 successive reboots… And I had no issue in the last 3 days.

2 Likes