Silent mode but vibration for incoming calls?

Dear all,

since the last system update one of my favorite settings of my fp2 seems to be gone.
I always had my phone in silent mode except for incoming calls in which case my phone would vibrate. Now it seems that my only two options are absolute silence or a vibration whenever a call or message or just a pop up notification is coming in.

I absolutly LOVED my setting and am quite unhappy about how it is now.

Does anyone have a solution for me?

Thanks a lot!

Do you mean an option in “Do not disturb” (the ‘one-way traffic sign’ icon)?

At least in the normal FP OS 19.08.1, it is still possible to select “Only priority” there, and in the settings you can choose which notifications have priority. It is possible to select phonecalls there.

Please clarify whether you are indeed running this operating system, or installed an alternative one such as FP Open OS or LineageOS.


Yes, that is the Software Version that i am using.
In my understanding my phone is indeed in do not disturb mode (I can see that icon in the upper right corner of my phone) and I also selected alarms and all incoming calls as priorities. But still no vibration or sound when I get a call…
But surprisingly the alarm does make a sound…

Thanks for your reply!

Did you use the same option in the previous OS? Your first post suggested that the option you used has been removed, but this sounds like the option is still there but not working anymore. It sounds like a software bug. Ideally, someone else should try the same on another FP2 with 19.08.1 to see whether it’s reproducible.

I felt like the option was removed but yes probably I used the same option and it is a bug…

And I tried around a bit more and found that under settings - sounds - do not disturb the priorities are set to be alarms and calls from all callers but when I press the volume down bottom the do not disturb sign appears and next to it it says: only alarms until deactivation.

So although I selected all calls to be a priority it appears that the system is not getting that…

Does anyone else experience this problem?


Did you try changing ‘only alarms’ to ‘only priority’ or does it change itself back every time you use the volume buttons?

Do you mean in this interface?

This interface seems to be gone, that’s what I meant with the missing feature. I can’t get there anymore…

It looks like the screenshot came from an older Android version. Did you recently upgrade your device from Android 5 or 6 to Android 7?

I indeed see that the phone switches to alarms only on pressing the volume button. However the interface is still available if you swipe down from the top of the screen and tap “Do not disturb”. There you can select “Only priority” at the top (where the three icons are in the screenshot).

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.