Several Languages for Keyboard

Hi everyone,

I would like to use several languages in my Keyboard (for example german and english). I could do that on the old Android 4.x and I’ve read how todo it (in theory) with Android 5. Unfortunately on my new FP2, I can not activate other languages than the system language. I can see the buttons to activate other languages but it is not possible to pull them to the right. Does anyone have a solution?

Kind regards,

1 Like

I don’t know what you mean by that, but to get more languages you have to go to:
Settings > Language & Input > Android Keyboard (or whichever is the name of the keyboard you use; it should be the second point under “keyboard & input methods” though.) > Languages > tick every language you like.

Now if you write you can switch between languages with the symbol that looks a bit like a globe. Your current language will be written on the space bar.

This could be a bit different with other keyboards.



I fully support that - the keyboard is really rally good (I tried several others, but the FP2 is the best), but it lacks a number of things (at least I don’t find the related config options):

  1. have e.g. German keyboard when you have English language on the phone (as said in the first posting here)

  2. option to switch off the vibration-feedback (browsing during the night whilst laying awake with jetlag will wake up my dear love, sleeping next to me)

  3. option to switch off auto-correct (just that), but keep proposing words whilst typing. The auto-correct is not very useful when e.g. typing half of the messages in German, the others in English.

  4. easier adding new words to my private dictionary - so far I have to write down my private webpage/e-mail/messenger-id again and again

  5. long-press autotext - some phones have this, so I press e.g. “1” for a bit longer and then it writes a pre-configured text, such as “this is some auto-text”. It’s a nice-to have, just a wish from me.

As said: the keyboard is great, I will keep on using it anyhow, but if you change something, maybe you want to consider also these things.

Cheers from Vienna,

I suggest you download SwiftKey. It’s the best for me…

check it out here


Hi Paul,

thanks for your response. What I mean is this: I can see the fields to “tick” the language that I want. But if I try to tick them nothing happens. They are also greyish, so I suppose they are deactivated or something.

Then you first have to untick “system language”.

I think that one is solved now.

Settings > Language & Input > Android Keyboard > Preferences > Vibrate on keypress

Settings > Language & Input > Android Keyboard > Text Correction > Auto Correction Off + Show Suggestions On

Right back at you, :wink:


Thank you! Danke! i’m the master of blindness and not finding configuration options. For people like me it is easier to ask questions on the forum than finding what is right in front of their eyes :smile:.

Cheers V2V,


That worked. Thank you very much!

1 Like