Settings > Apps > Unfortunately settings has stopped

Hello, I can’t access the menu Settings > Apps any more, every time “Apps” crashes and I see the message “Unfortunately settings has stopped”. That’s annoying since I need access to the Apps. Thanks for any advice!

Do you have any disabled apps?

Yes, quite a few, I think. I disabled them when I got my fairphone.

You should reenabled them all, reboot the phone and check if the problem still exists.

Hm, I would like to do that, but I can’t access the menu Settings > Apps because the above message appears instantly and the menu closes. Do you know another way to reenable apps?

Oh, right, I forgot that this is a little bit of a Dilemma. :sweat_smile: Well, unless someone else knows a way or an app which can do things like reset disabled apps, I only see the radical solution of doing a factory reset of your FP2.

But at least, this would fix any other issues that could cause the described behaviour, if it’s not the disabled apps.

But before, you could try if wiping the cache partition has any effect. For that, you shut down your phone and boot it by holding Power + Vol. up until you enter the recovery mode. There you select “wipe cache partition” using the vol. buttons for navigation and the power button for selection. Finally reboot the phone and check if the issue still exists.

1 Like

Oh, I already feared that :confused: I tried wiping the cache partition, but that didn’t help. So I’m gonna try the factory reset as soon as I have time. Thank you so much for your help! :slight_smile:

Try titanium backup.
If you go into the app list (backup & restore) and click on an app, you can unfreeze frozen apps from there as well.

Disable Manager could work, maybe, opening the specific app system settings. As far as I know, Titanium requires root permissions.
If you can access said settings, try deleting data for the Settings app.

If you can’t either way, there’s a way with adb from the computer, using the pm command (Package Manager).

Hi Freibadschwimmer and Roboe, thanks for your answers :smile: ! I tried several app managers and always got the above message. As soon as I have more time I’ll try it with adb or, if nothing works, I’ll do a factory reset …

1 Like

Terminal Emulator way (within Android, root needed)

pm clear

You should see a Success message if everything went fine.

ADB way (from an external computer, not sure if root is needed)

Set up ADB on your machine, connect your phone via USB, open a terminal and launch:

adb shell
pm clear

If root permissions are needed, you should see an Error message. If everything went fine, you should see a Success message.

Type exit to leave ADB.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.